AnsweredAssumed Answered

Errors while setting alfresco development env in eclipse

Question asked by zarrakh_8 on Oct 15, 2010
Latest reply on Oct 18, 2010 by zarrakh_8
Hi,
     I have download alfresco 3.2 source code form svn root. I am using eclipse helious. While importing the source code i faced a lot of problems and solved few of them which are as follows

   1. I was forced to use jdk 1.5, jdk 1.6 didn't worked

   2. By default ant or eclipse use modern compiler, So iv added <compilearg> in macro.xml to use jdt compiler.

   3. lot of memory heap error occured.. but solved by adding Xms and Xmx value in VM Args

   4. Now i am trying to compile only one module i.e compile-webclient. Total 85 errors and lot of warnings. I have included all the required alfresco jar files in 3rd-party lib project.  Out of 85 errors lot of errors are like"cannot find symbol". Eg

       -> D:\Alfresco Configuration files\Alfresco source\root\projects\web-client\source\java\org\alfresco\web\app\servlet\AuthenticationHelper.java:40: cannot find symbol
    [javac] symbol  : class RemoteUserMapper
    [javac] location: package org.alfresco.repo.webdav.auth
    [javac] import org.alfresco.repo.webdav.auth.RemoteUserMapper;



    –>   D:\Alfresco Configuration files\Alfresco source\root\projects\web-client\source\java\org\alfresco\web\sharepoint\auth\AbstractAuthenticationHandler.java:26: cannot find symbol
    [javac] symbol  : class AuthenticationDriver
    [javac] location: package org.alfresco.repo.webdav.auth
    [javac] import org.alfresco.repo.webdav.auth.AuthenticationDriver;

and so on……..

     Can anybody tell me how to solve these errors and make the source build properly i.e error free..


Thanks & Regards
Zarrakh

Outcomes