AnsweredAssumed Answered

Problemas al arrancar Tomcat con Windows y Alfresco Labs

Question asked by nanija on Feb 3, 2009
Latest reply on Feb 3, 2009 by nanija
Hola de nuevo:
Estoy instalando Alfresco Labs 3 en Windows bajo Tomcat.(El paquete full, con todo lo necesario)
Puedo arrancar el servidor, aunque con una serie de problemas.
He estado viendo los que son en alfresco.log; aunque he intentado solucionarlos, no he sabido muy bien como hacerlo.
A continuación pongo el contenido de este fichero por si alguien me puede echar una mano.
Gracias de antemano.


12:51:41,078 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
12:51:59,000 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
12:51:59,500 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaCreate-org.hibernate.dialect.MySQLInnoDBDialect-43241.sql (Generated).
12:52:04,437 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-43242.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-MappedFKIndexes.sql).
12:52:04,437 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-43243.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-Extra.sql).
12:52:05,359 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-43244.sql (Copied from classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/post-create-indexes-04.sql).
12:52:05,390 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Executing database script C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-43245.sql (Copied from classpath:alfresco/dbscripts/create/3.0/org.hibernate.dialect.MySQLInnoDBDialect/create-activities-extras.sql).
12:52:05,593 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] All executed statements written to file C:\Alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-All_Statements-43246.sql.
12:52:50,500 ERROR [org.alfresco.util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
   os:         Windows XP
   command:    "C:/Alfresco/openoffice/OpenOffice.org/program/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///C:/Alfresco/openoffice/OpenOffice.org" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:       
   err:        Cannot run program ""C:/Alfresco/openoffice/OpenOffice.org/program/soffice"": CreateProcess error=3, El sistema no puede hallar la ruta especificada
12:52:50,921 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\Alfresco\alf_data
12:52:50,968 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
12:52:52,109 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]    Applying patch 'patch.wcmFolders' (Ensures the existance of the WCM specific 'Web Projects' and 'Web Forms' folders.).
12:52:52,437 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.db-V3.0-0-CreateActivitiesExtras
RESULT:
Script completed
=====================================
12:52:52,453 INFO  [org.alfresco.repo.admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.wcmFolders
RESULT:
The Web Projects folder was successfully created: workspace://SpacesStore/79294c79-8817-4ccd-bb6e-5f139a10ef6a
The Web Forms folder was successfully created: workspace://SpacesStore/79294c79-8817-4ccd-bb6e-5f139a10ef6a
=====================================
12:52:52,453 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
12:52:54,234 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
12:52:54,328 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 506,313MB
12:52:54,343 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (c 1342) schema 1000 - Installed version 3.0.0 (c 1342) schema 1000
12:52:55,921 WARN  [org.alfresco.linkvalidation.LinkValidationServiceImpl] LinkValidationService Update is not running (virtualization server not registered or started)
12:53:25,921 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
12:53:25,937 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 175.11555ms)
12:53:26,656 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 134 Web Scripts (+0 failed), 136 URLs
12:53:26,671 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 728.26404ms)
12:53:27,171 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
12:53:40,281 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:18:07,156 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
13:18:27,093 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
13:18:29,843 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
13:18:32,078 ERROR [org.alfresco.util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
   os:         Windows XP
   command:    "C:/Alfresco/openoffice/OpenOffice.org/program/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///C:/Alfresco/openoffice/OpenOffice.org" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:       
   err:        Cannot run program ""C:/Alfresco/openoffice/OpenOffice.org/program/soffice"": CreateProcess error=3, El sistema no puede hallar la ruta especificada
13:18:34,265 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\Alfresco\alf_data
13:18:34,328 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
13:18:34,687 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
13:18:34,687 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
13:18:36,437 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
13:18:36,578 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 506,313MB
13:18:36,593 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (c 1342) schema 1000 - Installed version 3.0.0 (c 1342) schema 1000
13:18:36,968 WARN  [org.alfresco.linkvalidation.LinkValidationServiceImpl] LinkValidationService Update is not running (virtualization server not registered or started)
13:19:11,578 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
13:19:11,578 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 192.432ms)
13:19:13,390 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 134 Web Scripts (+0 failed), 136 URLs
13:19:13,406 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 1821.128ms)
13:19:13,796 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:19:23,968 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:26:49,109 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
13:27:06,046 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
13:27:07,703 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
13:27:11,843 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\Alfresco\alf_data
13:27:11,921 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
13:27:12,265 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
13:27:12,281 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
13:27:14,343 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
13:27:14,390 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 506,313MB
13:27:14,390 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (c 1342) schema 1000 - Installed version 3.0.0 (c 1342) schema 1000
13:27:14,843 WARN  [org.alfresco.linkvalidation.LinkValidationServiceImpl] LinkValidationService Update is not running (virtualization server not registered or started)
13:27:52,953 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
13:27:52,968 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 203.0543ms)
13:27:54,156 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 134 Web Scripts (+0 failed), 136 URLs
13:27:54,156 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 1188.2229ms)
13:27:54,546 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:28:00,890 INFO  [org.alfresco.util.OpenOfficeConnectionTester] The OpenOffice connection was re-established.
13:28:03,703 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

Outcomes