AnsweredAssumed Answered

Je viens d'installer Alfresco avec la configuration...

Question asked by unknown-user on May 17, 2006
Latest reply on May 20, 2006 by unknown-user
Bonjour,

Je viens d'installer Alfresco avec la configuration Apache 2 + mod_jk 1.13 + Tomcat 5 + MySQL 5, et j'utilise donc Tomcat grace à un connecteur AJP.

Donc aulieu d'avoir dans le fichier server.xml:

<Connector port="8080" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               connectionTimeout="20000" disableUploadTimeout="true" />

J'ai:
<Connector
        port="9080"
        redirectPort="8443"
        disableUploadTimeout="true"
        minSpareThreads="25"
        connectionTimeout="20000"
        maxSpareThreads="75"
        maxThreads="150"
        acceptCount="100"
        maxHttpHeaderSize="8192"
        protocol="AJP/1.3">
    </Connector>

Je suis la procédure d'install et tou va bien… sauf au moment de s'authentifer:
Je vais sur l'addresse d'alfresco http://hostname/alfresco, et déja je ne tombe pas sur l'environnement "guest" mais directement sur la page de login.

Je tape alors admin/admin et je n'arrive pas à m'authentifer. "Impossible de se connecter - nom d'utilisateur/mot de passe inconnu."

Or je vérifie: la création de la base MySQL est OK, et j'arrive à me connecter en "alfresco" dessus, en ligne de commande mysql -ualfresco -palfresco -hlocalhost.

Je met Tomcat en mode DEBUG, et je ne vois pas de problème au niveau du connecteur JDBC/MySQL.

Je le relance alors, et je revais sur la page d'acceuil, et OH SURPRISE je suis dans l'environnement "guest", je fais une tentative de log en admin et ça marche aussi…
Bref j'arrete tout pour remettre en mode de trace NORMAL  et la rebelote ça ne marche plus…

Dans les logs je vois des erreurs du au fait qu"alfresco ne trouve pas OpenOffice, je l'installe et je redémarre et la je peux plus aller sur l'environnement "guest" mais j'arrive à m'authentifier en "admin"…

Ma question est : comment expliquer ce comportement ?

De plus que faire pour configurer samba et mon serveur proFTPd pour ne plus avoir ces erreurs au démarrage de Alfresco:

16:13:31,688 ERROR [org.alfresco.smb.protocol.netbios] NetBIOSNameServer setup error:
java.net.BindException: Permission denied
        at java.net.PlainDatagramSocketImpl.bind0(Native Method)
        at java.net.PlainDatagramSocketImpl.bind(PlainDatagramSocketImpl.java:82)
        at java.net.DatagramSocket.bind(DatagramSocket.java:368)
        at java.net.DatagramSocket.<init>(DatagramSocket.java:210)
        at java.net.DatagramSocket.<init>(DatagramSocket.java:261)
        at java.net.DatagramSocket.<init>(DatagramSocket.java:234)
        at org.alfresco.filesys.netbios.server.NetBIOSNameServer.openSocket(NetBIOSNameServer.java:1080)
        at org.alfresco.filesys.netbios.server.NetBIOSNameServer.run(NetBIOSNameServer.java:1504)
        at java.lang.Thread.run(Thread.java:595)
16:13:31,703 ERROR [org.alfresco.smb.protocol] [SMB] Server error :
java.net.BindException: Permission denied
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
        at java.net.ServerSocket.bind(ServerSocket.java:319)
        at java.net.ServerSocket.<init>(ServerSocket.java:185)
        at java.net.ServerSocket.<init>(ServerSocket.java:141)
        at org.alfresco.filesys.smb.server.SessionSocketHandler.initialize(SessionSocketHandler.java:249)
        at org.alfresco.filesys.smb.server.NetBIOSSessionSocketHandler.createSessionHandlers(NetBIOSSessionSocketHandler.java:157)
        at org.alfresco.filesys.smb.server.SMBServer.run(SMBServer.java:522)
        at java.lang.Thread.run(Thread.java:595)
16:13:31,703 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_06-b05; maximum heap size 493.063MB
16:13:31,704 ERROR [org.alfresco.ftp.protocol] FTP Socket error
java.net.BindException: Permission denied
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
        at java.net.ServerSocket.bind(ServerSocket.java:319)
        at java.net.ServerSocket.<init>(ServerSocket.java:185)
        at java.net.ServerSocket.<init>(ServerSocket.java:141)
        at org.alfresco.filesys.ftp.FTPNetworkServer.run(FTPNetworkServer.java:377)
        at java.lang.Thread.run(Thread.java:595)

Ensuite pourquoi ais-je l'avertiossement suivant?

16:13:31,704 WARN  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 493.063MB is less
than recommended 512MB


Merci de vos réponses,

Cdlt,

Outcomes