AnsweredAssumed Answered

About non-English characters

Question asked by jilingshu on Nov 18, 2010
Latest reply on Dec 20, 2010 by yushuo
hi there,
I am in China and I wanna upload Chinese Word files to Alfresco Explorer. But When I clicked on the "Add Content" and selected a file, it would ask me to input "General Properties“. The "Name:" field cannot be Chinese or it would give a error, but this is not the most critical problem. When I modified the "Name:" field to English and click "Next", it would told me
Please correct the errors below then click OK.

    * Failed to create content due to error: 10170047 Failed to write property deltas: Node: 780 Old: {} New: {{http://www.alfresco.org/model/content/1.0}description={en_US=null}, {http://www.alfresco.org/model/content/1.0}name=2010.xls, {http://www.alfresco.org/model/content/1.0}title={en_US=2010.xls}, {http://www.alfresco.org/model/content/1.0}author=雨林木风} Diff: {{http://www.alfresco.org/model/content/1.0}name=RIGHT_ONLY, {http://www.alfresco.org/model/content/1.0}description=RIGHT_ONLY, {http://www.alfresco.org/model/content/1.0}title=RIGHT_ONLY, {http://www.alfresco.org/model/content/1.0}author=RIGHT_ONLY} Delete Tried: [] Add Tried: {{http://www.alfresco.org/model/content/1.0}name=2010.xls, {http://www.alfresco.org/model/content/1.0}description={en_US=null}, {http://www.alfresco.org/model/content/1.0}title={en_US=2010.xls}, {http://www.alfresco.org/model/content/1.0}author=雨林木风}

I think this means the Author field of this Excel file cannot be Chinese. But I cannot modify it in the web page. Because of this, I cannot add this file to Alfresco. Is this a bug? thx

BTW: In Share, I also found I cannot create a file with Chinese Title/Filename,Description. Only content can be non-English. Even this, the non-English character would not be shown correctly in document details.

Outcomes