AnsweredAssumed Answered

Accent in myspaces webscript

Question asked by laurent1050 on Nov 18, 2010
Latest reply on Nov 22, 2010 by laurent1050
Hi all,

I'm testing the webscript http://.../alfresco/service/ui/myspaces that propose a new front to Alfresco.
No problems on my Windows server, but not the same on the RedHat one …

I've a problem with url encoding. If my folders have accents, the web script engine doesn't recognize them.

For example, the url :
http://.../alfresco/service/ui/myspaces?f=1&p=/Espace racine/Sites/serviss/documentLibrary/A ACTUALITES/01-Sécurité
is transformed (in both IE6 and FF3) in
http://.../alfresco/service/ui/myspaces?f=1&p=%2FEspace%20racine%2FSites%2Fserviss%2FdocumentLibrary%2FA%20ACTUALITES%2F01-S%C3%A9curit%C3%A9
And if I try to show the url in the user view :
${args.p} –> /Espace racine/Sites/serviss/documentLibrary/A ACTUALITES/01-Sécurité

And finally, companyhome.childByNamePath[path[(chLen+2)..]]?exists is false

Does someone have a solution to encode my url or to configure my server correctly ?

Thanks,
Laurent

———————-

I've found a post with the same problem, but without solution :
http://forums.alfresco.com/en/viewtopic.php?f=36&t=26712&p=86977

I'm using Alfresco 3.3 on a RedHat server with Tomcat 6
Tomcat use UTF-8 encoding
<Connector port="8080" protocol="HTTP/1.1" URIEncoding="UTF-8"
   connectionTimeout="20000"
   redirectPort="8443" />
Server locale is fr_FR.UTF-8
[root@RDL6V041 ~]# locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

Outcomes