AnsweredAssumed Answered

Cannot delete a file in Share

Question asked by lordnacho on Nov 23, 2010
Latest reply on Nov 29, 2010 by lordnacho
Hello all,

After my predecessor at my job installed and initially configured Alfresco Share, I have been tasked with its subsequent implementation and support. I've been playing with it, making sites, and uploading content on a test basis to familiarize myself with the way it works. I've also been reading most of the documentation that Alfresco makes available in .pdf format. This morning I tried to delete one of the files that I uploaded just as a test and I received an error stating: "Could not delete 'Test File.doc'"

I tried some preliminary research to find a solution and even after removing the space in the file name, moving the file into another folder and trying to delete it there, trying to delete the entire folder, and trying to delete the entire site itself all fail to remove the file. I can add and remove aspects normally with the exception of "Versionable" which throws an error when I try and remove it. I suspect this may be part of the problem. Also, when I view the site dashboard, the Recently Modified Documents widget displays the following error:

10230003 Wrapped Exception (with status template): 10230005 Failed to execute script 'classpath*:alfresco/templates/webscripts/org/alfresco/slingshot/documentlibrary/doclist.get.js': 10230004 Failed to execute search: +PATH:"/app:company_home/st:sites/cm:testsite/cm:documentLibrary//*" +@cm\:modified:[2010\-11\-16T00\:00\:00.000 TO 2010\-11\-23T23\:59\:59.999] -TYPE:"{http://www.alfresco.org/model/content/1.0}folder" -TYPE:"{http://www.alfresco.org/model/content/1.0}thumbnail" -TYPE:"{http://www.alfresco.org/model/content/1.0}systemfolder" -TYPE:"{http://www.alfresco.org/model/forum/1.0}forums" -TYPE:"{http://www.alfresco.org/model/forum/1.0}forum" -TYPE:"{http://www.alfresco.org/model/forum/1.0}topic" -TYPE:"{http://www.alfresco.org/model/forum/1.0}post" -@cm\:lockType:READ_ONLY_LOCK +(TYPE:"{http://www.alfresco.org/model/content/1.0}content" OR TYPE:"{http://www.alfresco.org/model/application/1.0}filelink" OR TYPE:"{http://www.alfresco.org/model/content/1.0}folder")

I'm at a bit of a loss on this and would appreciate any help anyone could give. Thank you for your time.

Best,

Justin
IT Administrator Intern

Outcomes