AnsweredAssumed Answered

Content Integrity Error

Question asked by sherrykerry on Nov 23, 2010
Latest reply on Nov 24, 2010 by sherrykerry
I had to recreate alfresco database with utf8 char encoding.

I performed these steps:
1. Stop Alfresco
2. Delete alf data folder '/app/alfresco/alf_data_alfrescoSource3'
3. Created new database with correct encoding
4. Start ALfresco

After I start alfresco, I see that 'alf_data_alfrescoSource3' folder is created and these folders under this also created:
audit.contentstore
contentstore
contentstore.deleted
lucene-indexes

In the log file I see that Index is build 100% and then this error as below. When I check the status it says RUNNING, but I cannot his the alfresco console/ dashboard.
User:System INFO  [repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /app/alfresco/alf_data_alfrescoSource3
User:System ERROR [repo.admin.ConfigurationChecker] CONTENT INTEGRITY ERROR: System content not found in content store.
User:System ERROR [repo.admin.ConfigurationChecker] Ensure that the 'dir.root' property is pointing to the correct data location.
User:System ERROR [web.context.ContextLoader] Context initialization failed
org.alfresco.error.AlfrescoRuntimeException: Ensure that the 'dir.root' property is pointing to the correct data location.
        at org.alfresco.repo.admin.ConfigurationChecker.check(ConfigurationChecker.java:312)


log4j:ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
Exception in thread "LicenseVerifier_QuartzSchedulerThread" java.lang.NoClassDefFoundError: org.quartz.StatefulJob
        at org.quartz.JobDetail.class$(JobDetail.java:279)

In 'custom-repository.properties' I have:
index.recovery.mode=FULL
dir.root=/app/alfresco/alf_data_alfrescoSource3

I tried to find soln in your older posts and most of them say to perform the same steps as above. But that did not solve my problem.

Please help.

Outcomes