AnsweredAssumed Answered

problem running alfresco-wcm_examples-3.3 on virtual tomcat

Question asked by ggendreau on Nov 24, 2010
Latest reply on Nov 24, 2010 by mrogers
Hi

I installed Alfresco community 3.4; it works very nicely.  Then I tried to run the alfresco-wcm-examples-3.3\..\getting-started-sample;  when I tried to preview, I got:   Firefox can't establish a connection to the server at alfrescosample.www–sandbox.127-0-0-1.ip.alfrescodemo.net:8180

if I ping alfrescosample.www–sandbox.127-0-0-1.ip.alfrescodemo.net from my server, it return the 127.0.0.1; it is ok.

I checked the virtual server and I have to confess that it is not obvious to see what is going on.   I checked port 8180 with  netstat -p|grep 8180; nothing!  It looks to me that the virtual tomcat is not up.

Please tell me, do I have to run my standard alfresco (alfresco.sh start) and run in parallel   /alfresco/alfresco-3.4.a/virtual-tomcat/bin/startup.sh?  It looks to me that it does nothing.   It doesn't output anything in the log directory.    on Linux, I should  run sh virtual_alf.sh start..   This file is not in the comunity 3.4 distribution.

Is it necessary to run the samples with the virtual tomcat? 



Thanks


=============================================

I finally succeeded in having the VS working.

how ?
the default parameter for the VM are a little too small.. I inflated it a bit : -Xms512m -XX:MaxPermSize=200m  That way i didn't have PermGen error in the catalina.log file.  I did that for both VM (tomcat and virt-tomcat).

Then, I had to set environment variables prior to launch startup.sh, because by default, those variables point to the Alfresco based directory and virt-tomcat conflicts with the tomcatl already running.  When an atempt is made to use virt-tomcat, environement variables for the JVM must be set to ….virt-tomcat/bin directory.

Outcomes