AnsweredAssumed Answered

Unexpected EOF in prolog -- SOAP not fully transmitting

Question asked by jabailo on Nov 29, 2010
I developed a simple openCMIS client in jsf running on JBoss 4.3.2 using the Apache Chemistry openCMISClient api.

I tested against the Alfresco public site, http://cmis.alfresco.com and I was able to connect and iterate through documents.

Next, I tried testing with my own server – which is running the 30 day trial Enterprise edition.

I tried running my client both on a remote machine, and then on the same instance of JBoss.

In both cases it produces the following error when trying to connect to the repository:

com.sun.xml.ws.protocol.soap.MessageCreationException: Couldn't create SOAP message due to exception: XML reader error: com.ctc.wstx.exc.WstxEOFException: Unexpected EOF in prolog

This appears to have to do with the SOAP message not being fully transmitted.  I've turned off virus protection, but it still occurs.

I realize this isn't necessarily an AlFresco problem, but I'm wondering if others have similar issues and know of any fixes.

Outcomes