AnsweredAssumed Answered

Bonjour à tous,J'utilise Alfresco 2.0, et maintenant...

Question asked by grimko on Aug 8, 2007
Latest reply on Aug 28, 2007 by grimko
Bonjour à tous,

J'utilise Alfresco 2.0, et maintenant 2.1 en entreprise avec un environnement Linux et Tomcat 5.5.

Nous avons toujours eu un problème qui apparaît de manière périodique avec CIFS :
* au bout de quelques heures d'utilisation, les dossiers dont le nom comporte un accent ne peuvent plus s'ouvrir par CIFS, il n'y a alors pas d'autre solution que de relancer le serveur.
* j'ai activé le log de debug pour samba, et n'arrive pas à voir d'erreur liée au problème.

Souvent mais pas toujours l'état vérolé apparaît le matin, sachant qu'Alfresco est stoppé puis redémarré la nuit pour sauvegarde, que ce soit par un script ANT, ou en relançant le Tomcat.

L'interface Web permet toujours l'accès aux fichiers et dossiers avec accents.

Voici le fichier file-servers-custom.xml, avec redirection des ports SMB par le firewall :
<alfresco-config area="file-servers">
   <config evaluator="string-compare" condition="CIFS Server">
          <serverEnable enabled="true"/>
      <host name="${localname}_A" domain="WORKGROUP"/>
      <comment>Alfresco CIFS Server</comment>

      <!– Set to the broadcast mask for the subnet –>
      <broadcast>255.255.255.255</broadcast>

      <!– Can be mapped to non-privileged ports, then use firewall rules to forward requests from the standard ports –>
      <tcpipSMB port="1445" platforms="linux,solaris,macosx"/>
      <netBIOSSMB sessionPort="1139" namePort="1137" datagramPort="1138" platforms="linux,solaris,macosx"/>

      <hostAnnounce interval="5"/>

      <sessionDebug flags="Negotiate,Socket"/>
   </config>

Outcomes