AnsweredAssumed Answered

Suite à mon dernier message concernant l'utilisation...

Question asked by steamy on Aug 8, 2007
Latest reply on Aug 13, 2007 by steamy
Bonjour,

Suite à mon dernier message concernant l'utilisation des plug in et après la réponse de MichaelH, merci encore, je tente d'upgrader la version tout en conservant mes infos dans MySQL.

J'ai téléchargé la dernière version d'Alfresco (datée du 6 aout), fait l'install dans un répertoire  spécifique (alfresco2, pour l'install et la prépa) et modifié l'ensemble des fichiers tel que repris dans les divers README et posts:

- modif du 'repository.properties' pour spécifier l'emplacement de la partie alf_data (dir.root)
- modif du même fichier pour spécifier l'utilisation des emails (serveur, adresse, etc.)
- modif du même fichier pour le param spécifiant la récupération de l'index.
- modif des fichier 'custom-repository.properties' et 'custom-hibernate-dialect.properties' pour l'utilisation de MySQL

Ensuite, j'ai stoppé la version active (Installed version 2.1.0 (R1 443) schema 62) et renommé mes répertoires 'alfresco' et 'alfresco2' afin de pouvoir lancer la nouvelle version préparée (je ne peux donner les infos vu mon erreur).  'alfresco' est donc devenu 'alfresco1' et 'alfresco2' est devenu 'alfresco'.

Au lancement, l'application semble démarrer correctement mais signale ne pas pouvoir mettre à jour le schéma et termine son lancement en signalant 'une erreur de démarrage'.
Voici les premières lignes signalant se problème de schéma.

19:27:47,772 INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
19:28:48,007 ERROR [domain.schema.SchemaBootstrap] Echec de la mise à jour automatique du schéma
org.alfresco.error.AlfrescoRuntimeException: A previous schema upgrade failed.  Revert to the original database before attempting the upgrade again.
        at org.alfresco.error.AlfrescoRuntimeException.create(AlfrescoRuntimeException.java:46)
        at org.alfresco.repo.domain.schema.SchemaBootstrap.setBootstrapStarted(SchemaBootstrap.java:394)
        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:762)
        at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)


un peu plus loin:
19:28:48,029 ERROR [web.context.ContextLoader] Context initialization failed
org.alfresco.error.AlfrescoRuntimeException: Echec de la mise à jour automatique du schéma
        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:815)
        at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)

puis encore

        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:762)
        … 34 more
19:28:48,031 ERROR [[Catalina].[localhost].[/alfresco]] Exception lors de l'envoi de l'évènement contexte initialisé (context initialized) à l'instance de classe d'écoute (listener) org.springframework.web.context.ContextLoaderListener
org.alfresco.error.AlfrescoRuntimeException: Echec de la mise à jour automatique du schéma
        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:815)
        at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)
        at org.springframework.context.event.SimpleApplicationEventMulticaster$1.run(SimpleApplicationEventMulticaster.java:77)
        at org.springframework.core.task.SyncTaskExecutor.execute(SyncTaskExecutor.java:49)


En relancant l'ancienne version d'Alfresco, il récupère bien la DB et son contenu que je peux parcourir avec mon browser.  La DB ne serait donc pas corrompue. 
Je n'ai pas déplacé le répertoire 'alf_data' du répertoire de lancement d'alfresco (nouvelle version) vers sa position normale spécifié par dir.root, pensant continuer à utiliser l'ancien alf_data. 

Est-ce là mon erreur ?
Ou aurais-je oublié une étape dans mes modifs?

Merci

Stefan

Outcomes