AnsweredAssumed Answered

Error al actualizar del 3.1.1 al 3.2

Question asked by fstnboy on Feb 4, 2010
Buenas tardes,

Tengo un behaviour que se ejecuta cuando un contenido es actualizado, antes tenia la version 3.1.1, pero al actualizarme a la version 3.2 me da el siguiente error….

org.alfresco.error.AlfrescoRuntimeException: 01040003 Transaction must be active and synchronization is required: Thread[defaultAsyncAction2,5,TraceableThreadGroup-3]
Exception in thread "defaultAsyncAction2" org.alfresco.error.AlfrescoRuntimeException: 01040004 Transaction must be active and synchronization is required: Thread[defaultAsyncAction2,5,TraceableThreadGroup-3]
   at org.alfresco.repo.transaction.AlfrescoTransactionSupport.registerSynchronizations(AlfrescoTransactionSupport.java:460)
   at org.alfresco.repo.transaction.AlfrescoTransactionSupport.getSynchronization(AlfrescoTransactionSupport.java:444)
   at org.alfresco.repo.transaction.AlfrescoTransactionSupport.getResource(AlfrescoTransactionSupport.java:237)
   at org.alfresco.repo.transaction.TransactionalResourceHelper.getList(TransactionalResourceHelper.java:108)
   at org.alfresco.repo.policy.BehaviourFilterImpl.enableBehaviour(BehaviourFilterImpl.java:103)
   at org.zaizi.alfresco.module.hithighlighter.HitHighlighterSearchIndexer$HitHightlighterTextExtractor.run(HitHighlighterSearchIndexer.java:296)
   at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
   at java.lang.Thread.run(Thread.java:637)

Alguien sabe porque?

Outcomes