AnsweredAssumed Answered

Sur une 2.1 community, j'ai suivi les recommandations...

Question asked by rgouyet on Oct 30, 2007
Latest reply on Jan 31, 2008 by nicolas_4463
Sur une 2.1 community, j'ai suivi les recommandations pour faire Fonctionner NTLM en passthru. (avec AD).
Le serveur de test est sous windows.

Avec Firefox et la modification de network-automatic-ntlm-auth.trusted-uri  ça marche
avec IE6 sans modifications ça marche.
avec IE7, il m'affiche un popup pour me connecter et la connexion échoue.

Au niveau des logs :
avec IE6 (ou firefox)

18:14:34,914 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] New NTLM auth request from 10.10.10.10 (10.10.10.10:2459)
18:14:34,946 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type1 [Type1:0xa208b207,Domain:XXXXXXXXX,Wks:YYYYYYY]
18:14:35,024 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Sending NTLM type2 to client - [Type2:0x80000203,Target:ECMIRIUMTEST,Ch:10f208d375e74a45]
18:14:35,039 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type3 [Type3:,LM:11c361d8bba5d7ab7329a1ac46714e7dfc138b49c7999f43,NTLM:11c361d8bba5d7ab7329a1ac46714e7dfc138b49c7999f43,Dom:XXXXXXXX,User:zzzzzzzz,Wks:YYYYYYYY]
18:14:35,071 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Updated cached NTLM details
avec IE7

18:07:50,287 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] New NTLM auth request from 10.10.10.10 (10.10.10.10:63067)
18:07:50,302 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type1 [Type1:0xa208b207,Domain:XXXXXXX,Wks:YYYYYYYY]
18:07:50,318 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Sending NTLM type2 to client - [Type2:0x80000203,Target:ECMIRIUMTEST,Ch:a52329e4e5007538]
18:07:50,318 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type3 [Type3:,LM:38efa59afd83d957a01da0ac032ae8809687c98cf9dc3eb9,NTLM:eb25408542dc61c5aab56cdfb6d8aff201010000000000006c6b4f66171bc8019687c98cf9dc3eb90000000002001800450043004d0049005200490055004d0054004500530054000000000000000000,Dom:XXXXXXXXXX,User:ZZZZZZZ,Wks:YYYYYYYY]
18:07:50,334 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Authentication failed, Logon failure
18:07:58,474 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type1 [Type1:0xa2088207,Domain:<NotSet>,Wks:<NotSet>]
18:07:58,490 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Sending NTLM type2 to client - [Type2:0x80000203,Target:ECMIRIUMTEST,Ch:042d37c5ee7ece1a]
18:07:58,490 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Received type3 [Type3:,LM:decedc870819d95083063147a73672bc7c72cc6ccc45b988,NTLM:b8ecd2c1ca9fb8ac2661c30645f6e62e01010000000000001ca8306b171bc8017c72cc6ccc45b9880000000002001800450043004d0049005200490055004d0054004500530054000000000000000000,Dom:XXXXXXXXXX,User:ZZZZZZZ,Wks:YYYYYYYY]
18:07:58,505 DEBUG [org.alfresco.web.app.servlet.NTLMAuthenticationFilter] Authentication failed, Logon failure
La clef Type3 transmise par IE7 est beaucoup plus longue que pour celle de firefox.

J'ai bien essayé de modifier des options dans la config d'IE7 :
Dans advanced : Enable Integrated Windows Authentication (c'était décoché, j'ai coché)
Dans security : user authentication : j'ai essayé les différents choix.

Sans success

Une idée ?

Outcomes