AnsweredAssumed Answered

Web Service Client Alfresco 3.2r2 JDK 1.4

Question asked by dewil on Mar 19, 2010
Latest reply on Jul 2, 2015 by danjorman
Buenas tod@s.

Como prometi, ya es hora de contribuir un poco a esta comunidad. No sé si alguien se habrá encontrado el problema de tener que conectar por Web Service Alfresco con una aplicacion que trabaja con la JDK 1.4, a mi me ha pasado y he tenido que reescribir algunas clases que no compilaban (StringBuilder,genericos, anotaciones, uso de hilos…) para luego generarme un JAR compilado con la JDK 1.4.

Como no se pueden adjuntar archivos directamente en el FORO he subido los archivos a FILE DROPPER (de momento los he tenido que subir aquí, si es muy interesante y lo podemos subir a algún sitio mejor actualizaré este hilo):

Libreria JAR compilada con JDK 1.4: http://www.megaupload.com/?d=RDTX4GMB

SDK de las clases del JAR: http://www.megaupload.com/?d=0T6MZPAN

Como nota os comento que de todos los paquetes que trae el JAR oficial del Web Service Client de Alfresco, no he añadido "org.alfresco.webservice.test", ya que no es necesaria y presentaba demasiados problemas que habia que manipular para poder compilarla con la JDK 1.4.

Un saludo a tod@s.

Outcomes