AnsweredAssumed Answered

Problema de instalación en Debian Lenny (solución)

Question asked by juanla on Apr 6, 2010
Latest reply on Apr 8, 2010 by juanla
Bueno, he estado leyendo algunos problemas de otros usuarios pero no  he conseguido solucionarlo, por lo que tengo entendido Alfresco ha "suavizado" mucho la instalación, o la he suavizado yo  :lol:, Bueno, os digo lo que he hecho:

  1. Instalo Java

  2. Instalo Mysql-server

  3. Descargo la trial de Alfresco Enterprise Manager de la web

  4. La doy permisos de ejecución

  5. La ejecuto y lo instalo lo más "típico" posible, en cuanto a la parte de OpenOffice me la salto cambiando la ruta por la misma de la instalación de alfresco (1 vez pude instalarlo así)

  6. Lo conecto con mysql y aparentemente me dice que que crea la base de datos correctamente, bueno termina la instalación bien en teoría..

  7. Edito el archivo /opt/Alfresco/alfresco.sh modifico la ruta de alfresco y la de java

  8. Ejecuto el archivo alfresco.sh con su start correspondiente, observo que tomcat se levanta con él en el puerto que debe, pero al acceder a http://localhost:8080/alfresco me dice que el recurso no está disponible.
  9. El recurso requerido () no est� disponible.
He echo los pasos que os he dicho, ni uno más, ni cree usuarios, ni otras carpetas ni nada, solo eso, conseguí instalarlo en una máquina y en otra no, las 2 eran Debian y estaban limpias, la instalé de nuevo en otra y sigue igual.. os dejo el log por si alguien saca algo en claro, o si me salté algo me pueda indicar

   at org.alfresco.web.app.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:69)
   at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
   at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:627)
   at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
   at org.apache.catalina.core.StandardService.start(StandardService.java:516)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Caused by: java.net.UnknownHostException: trunks: trunks
   at java.net.InetAddress.getLocalHost(InetAddress.java:1353)
   at org.alfresco.repo.node.db.hibernate.HibernateNodeDaoServiceImpl.<init>(HibernateNodeDaoServiceImpl.java:237)
   … 106 more
22:49:18,571 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

Os dejo la respuesta al iniciarlo y como arranca tomcat (teoricamente está correcto, no?)

# /opt/Alfresco2/alfresco.sh start
Using CATALINA_BASE:   /opt/Alfresco2/tomcat
Using CATALINA_HOME:   /opt/Alfresco2/tomcat
Using CATALINA_TMPDIR: /opt/Alfresco2/tomcat/temp
Using JRE_HOME:       /usr/lib/jvm/java-6-sun
# netstat -putan |grep 8080
tcp6       0      0 :::8080                 :::*                    LISTEN      2489/java    
Eso sí, tras esperar y que me salga el mensaje de error de tomcat de recurso no entonctrado, al mirar de nuevo el netstat me sale esto:
# netstat -putan |grep 8080
tcp        0      0 127.0.0.1:51885         127.0.0.1:8080          ESTABLISHED 2434/firefox-bin
tcp6       0      0 :::8080                 :::*                    LISTEN      2489/java      
tcp6       0      0 127.0.0.1:8080          127.0.0.1:51885         ESTABLISHED 2489/java      

Comento que no se nada de Alfresco, lo intento instalar para configurarlo y toquetearlo y poco, vamos ir aprendiendo de él.

Cuando lo "apago" me devuelve esto, por si sirviera de algo:
# sh alfresco.sh stop
Using CATALINA_BASE:   /opt/Alfresco2/tomcat
Using CATALINA_HOME:   /opt/Alfresco2/tomcat
Using CATALINA_TMPDIR: /opt/Alfresco2/tomcat/temp
Using JRE_HOME:       /usr/lib/jvm/java-6-sun
CompilerOracle: exclude org/apache/lucene/index/IndexReader$1.doBody
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger.mergeIndexes
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger.mergeDeletions

El log no cambia al "apagarlo".

Archivo alfresco-global.propierties

###############################
## Common Alfresco Properties #
###############################

#
# Sample custom content and index data location
#————-
dir.root=/opt/Alfresco/alf_data

#
# Sample database connection properties
#————-
db.name=alfresco
db.username=alfresco
db.password=alfresco
db.host=localhost
db.port=3306

#
# External locations
#————-
ooo.exe=/opt/openoffice.org3/program/soffice
img.root=/usr/local
swf.exe=/opt/Alfresco/bin/pdf2swf

#
# MySQL connection
#————-
db.driver=org.gjt.mm.mysql.Driver
db.url=jdbc:mysql://${db.host}:${db.port}/${db.name}
hibernate.dialect=org.hibernate.dialect.MySQLInnoDBDialect

Outcomes