AnsweredAssumed Answered

salut  a toute la compagnieje suis nouveau sur alfresco...

Question asked by dakylla on Nov 12, 2007
Latest reply on Apr 28, 2008 by huberd
salut  a toute la compagnie

je suis nouveau sur alfresco et je cherche a le configurer pour kerberos/AD

j'ai l'erreur suivante (j'ai mis une bonne partie du debut du log serveur que vous ayez une vision plus large du probleme :):

17:29:43,093 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent] Récupération de l'index achevée.
17:29:43,109 INFO  [org.alfresco.repo.admin.ConfigurationChecker] Le répertoire racine de données d'Alfresco ('dir.root') est : C:intranetDATA
17:29:43,125 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Vérification des correctifs à appliquer …
17:29:43,359 INFO  [org.alfresco.repo.module.ModuleServiceImpl] 0 module(s) trouvé(s).
17:29:43,468 DEBUG [org.alfresco.smb.protocol] Local domain name is DOM (via JNI)
17:29:43,515 DEBUG [org.alfresco.smb.protocol.auth] CIFS Kerberos login using account cifs/ada@DOM.FR
17:29:43,796 DEBUG [org.alfresco.smb.protocol.auth] CIFS Kerberos login successful
17:29:43,812 INFO  [org.alfresco.smb.protocol] CIFS server started
17:29:43,812 INFO  [org.alfresco.smb.protocol] FTP server started
17:29:43,812 INFO  [org.alfresco.smb.protocol] NFS server NOT started
17:29:43,828 INFO  [org.alfresco.smb.protocol] SMB Server ADA starting
17:29:43,859 INFO  [org.alfresco.smb.protocol] GUID 347cbca8-5aed-3183-96cd-4f78b6509882
17:29:43,859 INFO  [org.alfresco.smb.protocol] Using authenticator org.alfresco.filesys.server.auth.EnterpriseCifsAuthenticator
17:29:43,859 INFO  [org.alfresco.smb.protocol] Server timezone Europe/Paris, offset from UTC = -1hrs
17:29:43,859 INFO  [org.alfresco.smb.protocol] Shares:
17:29:43,859 INFO  [org.alfresco.smb.protocol]  [Alfresco,DISK,,[Alfresco,workspace://SpacesStore/27c9e357-8c65-11dc-afce-add28bc2af1a]] [Alfresco,workspace://SpacesStore/27c9e357-8c65-11dc-afce-add28bc2af1a]
17:29:43,859 INFO  [org.alfresco.smb.protocol]  [AVM,DISK,,[AVM,VirtualView]] [AVM,VirtualView]
17:29:43,859 INFO  [org.alfresco.smb.protocol] Add Share [IPC$,IPC$,,Admin,Hidden] : true
17:29:43,890 DEBUG [org.alfresco.smb.protocol] Win32 NetBIOS Available LANAs: 0
17:29:43,906 DEBUG [org.alfresco.smb.protocol] Win32 NetBIOS server ADA (using Winsock)
17:29:44,078 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_03-b05; maximum heap size 1016,125MB
17:29:44,078 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.2.0 (dev @build-number@) schema 108 - Installed version 2.2.0 (dev @build-number@) schema 108
17:29:46,218 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] Exception au démarrage du filtre Authentication Filter
javax.servlet.ServletException: Required authentication mode not available  <================================================= ERREUR
   at org.alfresco.web.app.servlet.KerberosAuthenticationFilter.init(KerberosAuthenticationFilter.java:206)
   at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:221)
   at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:302)
   at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:78)
   at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:3635)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4222)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
   at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:920)
   at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:883)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:492)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
   at org.apache.catalina.core.StandardService.start(StandardService.java:448)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
17:29:46,234 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/alfresco]] Exception au démarrage du filtre WebDAV Authentication Filter
j'ai mis ceci dans file-servers-custom.xml

      <config evaluator="string-compare" condition="Filesystem Security">
         <authenticator type="enterprise">
            <KDC>ad.dom.fr</KDC>
            <Realm>DOM.FR</Realm>
            <Password>*******</Password>
         </authenticator>
j'ai ca dans java.login.config :

AlfrescoCIFS {
   com.sun.security.auth.module.Krb5LoginModule required
   storeKey=true
   useKeyTab=true
   keyTab="C:/Java/jdk1.6.0_03/jre/lib/security/alfrescocifs.keytab"
   principal="cifs/ad";
};

AlfrescoHTTP {
   com.sun.security.auth.module.Krb5LoginModule required
   storeKey=true
   useKeyTab=true
   keyTab="C:/Java/jdk1.6.0_03/jre/lib/security/alfrescohttp.keytab"
   principal="HTTP/ad";
};
j'ai aussi ca dans web.xml :

   <filter>
     <filter-name>Authentication Filter</filter-name>
     <filter-class>org.alfresco.web.app.servlet.KerberosAuthenticationFilter</filter-class>
     <init-param>
       <param-name>KDC</param-name>
       <param-value>ad.dom.fr</param-value>
     </init-param>
     <init-param>
       <param-name>Realm</param-name>
       <param-value>DOM.FR</param-value>
     </init-param>
     <init-param>
       <param-name>Password</param-name>
       <param-value>*******</param-value>
     </init-param>
  </filter>
 
  <filter>
     <filter-name>WebDAV Authentication Filter</filter-name>
     <filter-class>org.alfresco.repo.webdav.auth.KerberosAuthenticationFilter</filter-class>
     <init-param>
       <param-name>KDC</param-name>
       <param-value>ad.dom.fr</param-value>
     </init-param>
     <init-param>
       <param-name>Realm</param-name>
       <param-value>DOM.FR</param-value>
     </init-param>
     <init-param>
       <param-name>Password</param-name>
       <param-value>*******</param-value>
     </init-param>
  </filter>
========================


ad.dom.fr est le nom complet de mon serveur, son nom netbios etant ad.

J'ai suivi le howto qui se trouve ici : http://wiki.alfresco.com/wiki/Configuring_the_CIFS_and_web_servers_for_Kerberos/AD_integration
quelqu'un a deja eu ce genre de pb, et si oui comment l'a t'il reglé ?.


merci pr toutes réponses éventuelles

Outcomes