AnsweredAssumed Answered

Custon content modelling failed. Can't log in anymore

Question asked by frankb on Jan 7, 2011
Latest reply on Apr 6, 2011 by torquoise
Hi,

Trying to create custom models in Alfresco. First we tried creating the example model which is included (my:sop), and this worked.
But when we tried to create our own model, we ran into some problems.
I guess something in the configuration was wrong, and now we cannot log in anymore. Even when we remove the xml files with the new content model.
The message we get is :  The remote server may be unavailable or your authentication details have not been recognized.

In the alfresco.log there is some error messages:
14:24:01,687 DEBUG [org.apache.commons.httpclient.HttpConnection] Open connection to localhost:8080
14:24:01,689 DEBUG [httpclient.wire.header] >> "GET /alfresco/s/remotestore/has/alfresco/site-data/template-instances/slingshot-login.xml?s=sitestore HTTP/1.1[\r][\n]"
14:24:01,689 DEBUG [org.apache.commons.httpclient.HttpMethodBase] Adding Host request header
14:24:01,689 DEBUG [httpclient.wire.header] >> "User-Agent: Jakarta Commons-HttpClient/3.1[\r][\n]"
14:24:01,689 DEBUG [httpclient.wire.header] >> "Host: localhost:8080[\r][\n]"
14:24:01,689 DEBUG [httpclient.wire.header] >> "[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "HTTP/1.1 404 Not Found[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "HTTP/1.1 404 Not Found[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "Server: Apache-Coyote/1.1[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "Content-Type: text/html;charset=utf-8[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "Content-Length: 952[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "Date: Fri, 07 Jan 2011 13:24:01 GMT[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.header] << "[\r][\n]"
14:24:01,692 DEBUG [httpclient.wire.content] << "<html><head><title>Apache Tomcat/6.0.26 - Error report</title><style><!–H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}–></style> </head><body><h1>HTTP Status 404 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The requested resource () is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.26</h3></body></html>"
14:24:01,692 DEBUG [org.apache.commons.httpclient.HttpMethodBase] Resorting to protocol version default close connection policy
14:24:01,692 DEBUG [org.apache.commons.httpclient.HttpMethodBase] Should NOT close connection, using HTTP/1.1
14:24:01,692 DEBUG [org.apache.commons.httpclient.HttpConnection] Releasing connection back to connection manager.

There is also many more, but all of the messages is the same. 404 not found.

Any suggestions?

Frank

Outcomes