AnsweredAssumed Answered

Erreur Lucene au démarrage d'alfresco

Question asked by tcaiati on Dec 13, 2007
Latest reply on Dec 14, 2007 by tcaiati
Bonjour,

Nous utilisons alfresco community 2.2 sur Tomcat 5.5.
Nous testons la montée en charge de l'application en mettant 10 niveaux de Folder. Pour cela, nous utilisons :
http://wiki.alfresco.com/wiki/Server_Benchmarks
avec le fichier loader.properties :

session.name=10K-INITIAL
session.sourceDir=..
session.rmiUrls=rmi://localhost:50500/
session.storeIdentifiers=SpacesStore
session.folderProfile=1, 1, 2, 2, 2, 2, 2, 2, 2, 2, 2, 2
test.load.upload.fast=8, 0, 1000, 10, true
#test.load.totals.basic=1, 1000, 0, 0, true

Au démarrage de Tomcat, voici les traces, cela semble une erreur Lucene :

Traces Tomcat :

Caused by: java.lang.StackOverflowError
   at java.util.Hashtable.containsKey(Hashtable.java:307)
   at org.apache.lucene.index.SegmentReader.hasNorms(SegmentReader.java:421)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)
   at org.apache.lucene.index.MultiReader.hasNorms(MultiReader.java:155)
   at org.apache.lucene.index.FilterIndexReader.hasNorms(FilterIndexReader.java:113)


Nos options de lancement de Tomcat sont :
-Xms1024M -Xmx1024M -XX:PermSize=64M -XX:MaxPermSize=128M

Ce qui est inquiétant, c'est que l'appli alfresco ne démarre pas du tout.

Avez vous un idée :
1- du problème ?
2- pour redémarrer alfresco ?

Merci de votre aide et bonne journée,

Thomas

Outcomes