AnsweredAssumed Answered

Keyword-Search-Script returns Error 500 (was indexing issue)

Question asked by martyphee on Jan 18, 2011
Latest reply on May 6, 2011 by jerkins
Seems our issues with indexing are related to this topic http://forums.alfresco.com/en/viewtopic.php?f=9&t=34912.

I pulled the Lucene indexes down and searched for the node that was causing this error:

freemarker.template.TemplateModelException: get(properties) failed on instance of org.alfresco.repo.web.scripts.bean.KeywordSearch$SearchTemplateNode
.
.
.
Caused by: org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/1d2d8173-4394-4f7e-a5ce-5d2c224c1448
        at org.alfresco.repo.node.db.DbNodeServiceImpl.getNodePairNotNull(DbNodeServiceImpl.java:151)
        at org.alfresco.repo.node.db.DbNodeServiceImpl.hasAspect(DbNodeServiceImpl.java:842)
        at sun.reflect.GeneratedMethodAccessor276.invoke(Unknown Source)
Seems the entry is in the Workspaces index, but has been deleted and the document has moved.

stored,indexed,tokenized<ASSOCTYPEQNAME:{http://www.alfresco.org/model/content/1.0}CAMPUS_x0020_REGISTRAR_x0020_OFFICES_x0020_SERVICES_x0020_ONLY_x0020_SLA.doc>
stored,indexed,omitNorms<ID:workspace://SpacesStore/1d2d8173-4394-4f7e-a5ce-5d2c224c1448>
stored,indexed,omitNorms<LINKASPECT:>
stored,indexed,omitNorms<PARENT:archive://SpacesStore/e5b69f5c-cebc-4d53-93b6-b9f74f761a63>
stored,indexed,tokenized<PRIMARYASSOCTYPEQNAME:{http://www.alfresco.org/model/content/1.0}contains>
stored,indexed,omitNorms<PRIMARYPARENT:archive://SpacesStore/e5b69f5c-cebc-4d53-93b6-b9f74f761a63>
stored,indexed,tokenized<QNAME:{http://www.alfresco.org/model/content/1.0}CAMPUS_x0020_REGISTRAR_x0020_OFFICES_x0020_SERVICES_x0020_ONLY_x0020_SLA.doc>

I don't see any options to stop keyword search from finding these documents (deleted).  The only thing I found was to have the cleanup job scheduled to run every day, but this then gives 1 day for our queries to blow up. 

Anyone else experiencing this issue?  Is this a known issue with keywordsearch?

I was going to look at creating a custom keyword search class to filter out these, but really shouldn't have to do that.

Alfresco 3.2r
Oracle
Tomcat
Linux

Outcomes