AnsweredAssumed Answered

[solved]Alfresco CIFS is not working on windows 2008 server

Question asked by muralie39 on Feb 2, 2011
Latest reply on Feb 2, 2011 by muralie39
Hi,

  I am using the alfresco 3.4 version, i configures all the given settings but the cifs is not working.. please check my settings..

alfresco global settings..

cifs.enabled=true
cifs.serverName=KMKHUB
cifs.localname=KMKHUB
cifs.domain=ad.crisil.com
cifs.broadcast=255.255.255.0
cifs.disableNIO=true
cifs.disableNativeCode=true
cifs.bindto=172.21.152.57
cifs.hostannounce=true

& i copied the custom-file-servers-context.xml file to extension/subsystems/fileservers/default/default

i am getting the following error in the log file..


10:13:13,497  ERROR [org.alfresco.fileserver] [SMB] Server error : org.alfresco.jlan.server.config.InvalidConfigurationException: Error initializing session handler, Address already in use: JVM_Bind
10:13:13,512  ERROR [org.alfresco.fileserver] org.alfresco.jlan.server.config.InvalidConfigurationException: Error initializing session handler, Address already in use: JVM_Bind
org.alfresco.jlan.server.config.InvalidConfigurationException: Error initializing session handler, Address already in use: JVM_Bind
   at org.alfresco.jlan.smb.server.ThreadedCifsConnectionsHandler.initializeHandler(ThreadedCifsConnectionsHandler.java:206)
   at org.alfresco.jlan.smb.server.SMBServer.run(SMBServer.java:472)
   at java.lang.Thread.run(Thread.java:662)


1.Native SMB can be disabled by adding the registry key "SMBDeviceEnabled"=dword:00000000 within [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters] –completed this step

          2.Run the Windows Firewall with Advanced Security application. On Vista go to Control Panels, Administrative Tools. on Windows 2008 go to Start, Administrative Tools.

          3.Click on the Inbound Rules item in the left hand column.

          4.Scroll down to the File and Printer Sharing rules.

         a) The following rules should be enabled - File And Printer Sharing (NB-Datagram-In), File And Printer Sharing (NB-Name-In) and File And Printer Sharing (NB-Session-In).  –completed this step
         b) The File And Printer Sharing (SMB-In) rule should be disabled, this blocks the native SMB/port 445 traffic.  –completed this step
         c) The other File And Printer Sharing (…) rules are not required and can be left as is.  –completed this step

       The following steps may also help to disable SMB 2.0 on Windows 2008:

         1. Run regedit on Windows Server 2008 based computer.

         2. Expand and locate the sub tree [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters]

         3. Add a new REG_DWORD key with the name of Smb2
             * Value name: Smb2
             * Value type: REG_DWORD
                  * 0 = disabled –  –completed this step
             * 1 = enabled

               4. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.

          5. Reboot the server

Please provide suggestions to resolve this issue

Outcomes