AnsweredAssumed Answered

Lucene and indexing

Question asked by bgl on Feb 4, 2011
Latest reply on Feb 9, 2011 by mrogers
Hello,

I'm using Alfresco 3.4d community edition.

I have created a folder (using FileFolderService API) in the company home. When I search with the NodeBrowser, I have very strange results :

+PATH:"/app:company_home/*"

I get the list of folders as result. This is completely normal. Now, I try this :

+PATH:"/app:company_home/*" +@cm\:name:"folderName"

nothing is returned !!! I drop the lucene index and ask for full index at startup. Folder is still visible in the explorer. But if I run the previous query, Alfresco finds nothing.

Now I create a folder with Alfresco JSF UI. I make a search in the node browser (in Lucene mode) with the previous query :

+PATH:"/app:company_home/*" +@cm\:name:"folderName"

It is found. I stop Alfresco, drop indexes and replay the same query : nothing is found !!!!!

Can anyone explain me what is happening please. I cannot understand such behavior !! I have worked a lot with 3.2 and I have never seen such behavior !
Is 3.4.d version completely unstable ?

Thanks in advance for any explanations.

Outcomes