AnsweredAssumed Answered

Problème configuration CIFS

Question asked by mistermasque on Apr 22, 2008
Latest reply on Apr 25, 2008 by mistermasque
Bon je ne pense pas êter le premier à demander ça mais je n'arrive pas à configurer CIFS pour Alfresco.
J'utilise un serveur ubuntu 7.10 avec samba d'installé.
J'ai 2 cartes réseaux:
- une en IP fixe sur laquelle j'accède à Alfresco sur un LAN indépendant
- une en DHCP pour les mise à jour à partir du NET
Seule la carte en IP fixe est à prendre en compte.
J'ai Alfresco community 2.0 WAR

J'ai regardé un peu partout sur les forums mais pas moyen, je n'y arrive pas.
Les liens que j'ai regardé sont surtout:
http://forums.alfresco.com/viewtopic.php?f=9&t=833&p=3141

IP de base de ma carte réseau (eth1): 163.76.31.101
Netmask : 255.252.0.0
Broadcast : 163.79.255.255

J'ai créé une adresse IP virtuelle pour éviter le conflit avec samba:
ifconfig eth1:0 163.76.31.102

Alrs comme il était dit j'ai rajouté les lignes suivantes dans /etc/samba/smb.conf:

interfaces = 163.76.31.101/255.252.0.0
socket adress = 163.76.31.102
bind interfaces only = yes

J'ai modifié le fichier file-server.xml dans [..]/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/

<alfresco-config area="file-servers">

   <config evaluator="string-compare" condition="CIFS Server">
          <serverEnable enabled="true"/>
      <host name="${localname}_A"/>
      <comment>Alfresco CIFS Server</comment>

      <!– Set to the broadcast mask for the subnet –>
      <broadcast>163.79.255.255</broadcast>
      <bindto>163.76.31.102</bindto>
      <!– Use Java socket based NetBIOS over TCP/IP and native SMB on linux –>
      <tcpipSMB platforms="linux,solaris,macosx"/>
      <netBIOSSMB platforms="linux,solaris,macosx"/>

           <!– Can be mapped to non-privileged ports, then use firewall rules to forward
                    requests from the standard ports –>
          <!–
      <tcpipSMB port="1445" platforms="linux,solaris,macosx"/>
      <netBIOSSMB sessionPort="1139" namePort="1137" datagramPort="1138" platforms="linux,solaris,macosx"/>
          –>

      <hostAnnounce interval="5"/>

      <!– Use Win32 NetBIOS interface on Windows –>
      <Win32NetBIOS/>
      <Win32Announce interval="5"/>

<!–
      <WINS>
         <primary>1.2.3.4</primary>
         <secondary>5.6.7.8</secondary>
      </WINS>
–>
      <sessionDebug flags="Negotiate,Socket"/>
   </config>

   <config evaluator="string-compare" condition="FTP Server">
          <serverEnable enabled="true"/>
<!–      <debug flags="File,Search,Error,Directory,Info,DataPort"/> –>
   </config>

   <config evaluator="string-compare" condition="NFS Server">
          <serverEnable enabled="false"/>
   </config>

   <config evaluator="string-compare" condition="Filesystems">
          <filesystems>

                 <!– Alfresco repository access shared filesystem –>
         <filesystem name="Alfresco">
            <store>workspace://SpacesStore</store>
            <rootPath>/app:company_home</rootPath>

                        <!– Add a URL file to each folder that links back to the web client –>
                        <urlFile>
               <filename>__AlfrescoClient.url</filename>
               <webpath>http://${localname}:8080/alfresco/</webpath>


Je tente d'accéder à Alfresco par l'adresse
\\<nom_machine>_a

Mais rien y fait, en retour je n'ai pas de réponse. J'ai éssayé avec l'adresse ip:
163.76.31.101 répond par samba (je n'ai rien d'affiché vu que je ne partage pas de dossier)
163.76.31.102 ne répond pas

Voilà, je sais pas vraiment quoi faire…
Pouvez-vous m'éclairer un peu

Merci

Outcomes