AnsweredAssumed Answered

Alfresco 3.4c - Sharepoint problem

Question asked by pero on Feb 4, 2011
I am experiencing problems in opening document workspace site using Microsoft Word 2007 and Alfresco sharepoint module.

I have successfully created Share site from Microsoft Word 2007 using "Create Document Workspace" feature in word and from that point seems to me that everything is ok.

Now when I try to open document workspace site from Word by entering http://my_server:7070/alfresco under "Look in" inside Open dialog I get
"You cant open this location using this program. Please try different location."
and my alfresco log says

11:49:11,746 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:49:12,914 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:49:12,914 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:49:13,433 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:49:13,433 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication

If I enter http://my_server:7070/alfresco under "File name" inside Open dialog I get prompted for password. When I enter username/password I get
"The internet address 'http://my_server:7070/alfresco' is not valid"
and my alfresco log says

11:57:09,794 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:09,795 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:09,796 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Authenticating user "admin"
11:57:09,960 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Setting the current user to "admin"
11:57:09,963 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] User "admin" authenticated successfully
11:57:10,033 DEBUG [org.alfresco.module.vti.web.VtiFilter] User was authenticated successfully
11:57:10,033 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking if resource exists
11:57:10,053 DEBUG [org.alfresco.module.vti.handler] Resolved file info for 'alfresco' is null
11:57:10,110 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:10,110 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:10,261 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:10,261 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:10,626 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:10,626 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:10,633 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Setting the current user to "admin"
11:57:10,639 DEBUG [org.alfresco.module.vti.web.VtiFilter] User was authenticated successfully
11:57:10,640 DEBUG [org.alfresco.module.vti.web.VtiFilter] Return VTI answer for HEAD request
11:57:10,640 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Process request
11:57:10,640 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by specific rules
11:57:10,641 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Specific rule not found
11:57:10,641 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by pattern for uri='/_vti_inf.html'
11:57:10,641 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Action found for request
11:57:10,641 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Execute target action
11:57:10,804 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:10,805 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:10,806 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Setting the current user to "admin"
11:57:10,810 DEBUG [org.alfresco.module.vti.web.VtiFilter] User was authenticated successfully
11:57:10,810 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Process request
11:57:10,810 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by specific rules
11:57:10,810 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Specific rule not found
11:57:10,811 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by pattern for uri='/_vti_bin/shtml.dll/_vti_rpc'
11:57:10,811 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Action found for request
11:57:10,811 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Execute target action
11:57:10,825 DEBUG [org.alfresco.module.vti.web.actions.VtiBinAction] Executing vtiMethod: org.alfresco.module.vti.web.fp.ServerVersionMethod@599ae230
11:57:10,826 DEBUG [org.alfresco.module.vti.web.fp.ServerVersionMethod] Start method execution. Method name: server version
11:57:10,826 DEBUG [org.alfresco.module.vti.web.fp.ServerVersionMethod] End of method execution. Method name: server version
11:57:11,205 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:11,205 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:11,206 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Setting the current user to "admin"
11:57:11,210 DEBUG [org.alfresco.module.vti.web.VtiFilter] User was authenticated successfully
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Process request
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by specific rules
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Specific rule not found
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Find appropriate action by pattern for uri='/_vti_bin/shtml.dll/_vti_rpc'
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Action found for request
11:57:11,211 DEBUG [org.alfresco.module.vti.web.VtiRequestDispatcher] Execute target action
11:57:11,211 DEBUG [org.alfresco.module.vti.web.actions.VtiBinAction] Executing vtiMethod: org.alfresco.module.vti.web.fp.UrlToWebUrlMethod@65c4365
11:57:11,212 DEBUG [org.alfresco.module.vti.web.fp.UrlToWebUrlMethod] Start method execution. Method name: url to web url
11:57:11,215 DEBUG [org.alfresco.module.vti.handler.alfresco.v3.AlfrescoMethodHandler] WebUrl: /alfresco, fileUrl: ''
11:57:11,217 DEBUG [org.alfresco.module.vti.web.fp.UrlToWebUrlMethod] End of method execution. Method name: url to web url
11:57:11,719 DEBUG [org.alfresco.module.vti.handler.alfresco.v3.AlfrescoMethodHandler] WebUrl: /alfresco, fileUrl: ''
11:57:11,719 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:57:11,720 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication
11:57:11,720 DEBUG [org.alfresco.repo.security.authentication.AuthenticationComponentImpl] Setting the current user to "admin"
11:57:11,725 DEBUG [org.alfresco.module.vti.web.VtiFilter] User was authenticated successfully
11:57:11,725 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking if resource exists
11:57:11,732 DEBUG [org.alfresco.module.vti.handler] Resolved file info for 'alfresco' is null

I' am using alfresco-community-3.4.c-installer-linux-x64.bin on Ubuntu 10.10 x64 server.
My client is Windows 7 x64 with Microsoft Word 2007.

Any help please :|

Outcomes