AnsweredAssumed Answered

LDAP connection closed without sending a request

Question asked by maxime.corbeau on Feb 9, 2011
Hi all,

We've just installed Alfresco-3.4.c. The LDAP configuration from our working Alfresco-3.3g was copied into
tomcat/webapps/alfresco/WEB-INF/classes/alfresco/subsystems/Authentication/ldap/ldap-authentication.properties
ldap.authentication.java.naming.provider.url=ldap://localhost:389
ldap.synchronization.java.naming.security.principal=cn\=admin,dc\=example,dc\=com

LDAP was also enabled for our new Alfresco-3.4.c under
tomcat/shared/classes/alfresco-global.properties
authentication.chain=alfrescoNtlm1:alfrescoNtlm,ldap1:ldap

If I run a trace on l0 what I see is: SYN->SYN/ACK->ACK completed successfully and then straightaway the connection is closed by alfresco
1 0.000000    127.0.0.1             127.0.0.1             TCP      38639 > ldap [SYN] Seq=0 Win=32792 Len=0
2 0.000043    127.0.0.1             127.0.0.1             TCP      ldap > 38639 [SYN, ACK] Seq=0 Ack=1
3 0.000068    127.0.0.1             127.0.0.1             TCP      38639 > ldap [ACK] Seq=1 Ack=1 Win=32896
4 0.018231    127.0.0.1             127.0.0.1             TCP      38639 > ldap [FIN, ACK] Seq=1 Ack=1
5 0.018455    127.0.0.1             127.0.0.1             TCP      ldap > 38639 [FIN, ACK] Seq=1 Ack=2
6 0.018484    127.0.0.1             127.0.0.1             TCP      38639 > ldap [ACK] Seq=2 Ack=2 Win=32896

That's seems like a misbehavior to me as I would expect alfresco to at least make a bind request.

Outcomes