AnsweredAssumed Answered

Configuración Authorityy 3.4 Comunity, Error

Question asked by gabri124 on Apr 26, 2011
Latest reply on Apr 27, 2011 by yakon_8894
Hola, acabo de aterrizar en el mundo de alfresco y estoy en un proyecto que se debe migrar de la 2.2 a la 3.4 community. Este paso ya lo tengo realizado, la cosa está que necesito configurar el administrador del fichero Authorityy-services-context.xml

Antes funcionaba definiendo en la property el usuario y password

<property name="adminUsers">
            <set>
             <value>XXXX</value>
             <value>XXXXXXXX</value>
          </set>
        </property>

Pero en la nueva versión dicha propiedad no existe y si la pongo yo tal como la tenía antiguamente, me da el consiguiente problema:(no os copio todo para no aburriros)

Problemas con esa variable en el bean que antes si se podía usar, pero ahora no.

GRAVE: Excepción enviando evento inicializado de contexto a instancia de escuchador de clase org.alfresco.web.app.ContextLoaderListener

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'authorityService' defined in class path resource [alfresco/authority-services-context.xml]: Error setting property values; nested exception is org.springframework.beans.NotWritablePropertyException: Invalid property 'adminUsers' of bean class [org.alfresco.repo.security.authority.AuthorityServiceImpl]: Bean property 'adminUsers' is not writable or has an invalid setter method. Does the parameter type of the setter match the return type of the getter?
   at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:328)
   
   … 40 more


Alguien se encontró con esto?

Gracias

Outcomes