AnsweredAssumed Answered

Probleme CIFS

Question asked by pocchakool_2685 on Aug 4, 2008
Latest reply on Aug 4, 2008 by pocchakool_2685
Bonjour à tous,

J'essaie depuis quelques semaines de faire fonctionner le CIFS mais en vain.
Je peux mapper un lecteur réseau en local mais certaines machines sur le réseau n'y parviennent pas.
Elles peuvent "pinger" le serveur CIFS mais ne peuvent s'y connecter.

D'autres postes, n'ont pas ce souci et peuvent se connecter via CIFS sans problème.

Voici ma configuration:
-Windows XP pro
-Tomcat 5
-Alfresco 2.1
-HSQL

Voici les logs au démarrage du serveur:
CompilerOracle: exclude org/apache/lucene/index/IndexReader$1.doBody
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Mer
ger.mergeIndexes
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Mer
ger.mergeDeletions
4 ao¹t 2008 10:43:23 org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initialisation de Coyote HTTP/1.1 sur http-8080
4 ao¹t 2008 10:43:23 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 594 ms
4 ao¹t 2008 10:43:23 org.apache.catalina.core.StandardService start
INFO: DÚmarrage du service Catalina
4 ao¹t 2008 10:43:23 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
4 ao¹t 2008 10:43:23 org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
4 ao¹t 2008 10:43:24 org.apache.catalina.startup.HostConfig deployWAR
INFO: DÚploiement de l'archive alfresco.war de l'application web
10:44:05,764 WARN  [remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI re
gistry - creating new one
10:44:07,734 WARN  [alfresco.util.OpenOfficeConnectionTester] A connection to Op
enOffice could not be established.
10:44:11,752 INFO  [domain.schema.SchemaBootstrap] Schema managed by database di
alect org.hibernate.dialect.HSQLDialect.
10:44:11,752 INFO  [domain.schema.SchemaBootstrap] Alfresco is using the HSQL de
fault database. Please only use this while evaluating Alfresco, it is NOT recomm
ended for production or deployment!
10:44:12,112 INFO  [domain.schema.SchemaBootstrap] Aucune modification na ÚtÚ ap
portÚe au schÚma.
10:44:13,285 WARN  [repo.admin.ConfigurationChecker] The Alfresco 'dir.root' pro
perty is set to a relative path './alf_data'.  'dir.root' should be overridden t
o point to a specific folder.
10:44:13,285 INFO  [repo.admin.ConfigurationChecker] The Alfresco root data dire
ctory ('dir.root') is: .\alf_data
10:44:13,410 INFO  [admin.patch.PatchExecuter] VÚrification des correctifs Ó app
liquer …
10:44:13,472 INFO  [repo.module.ModuleServiceImpl] 0 module(s) trouvÚ(s).
10:44:13,941 INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_
07-b06; maximum heap size 493,063MB
10:44:13,941 WARN  [service.descriptor.DescriptorService] Alfresco JVM - WARNING
- maximum heap size 493,063MB is less than recommended 512MB
10:44:13,941 INFO  [service.descriptor.DescriptorService] Alfresco started (Comm
unity Network): Current version 2.1.0 (482) schema 64 - Installed version 2.1.0
(482) schema 64
4 ao¹t 2008 10:44:17 org.apache.coyote.http11.Http11BaseProtocol start
INFO: DÚmarrage de Coyote HTTP/1.1 sur http-8080
4 ao¹t 2008 10:44:17 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
4 ao¹t 2008 10:44:17 org.apache.catalina.startup.Catalina start
INFO: Server startup in 53927 ms

Et voici mon fichier file-server-custom.xml:
   <config evaluator="string-compare" condition="CIFS Server">
     <serverEnable enabled="true"/>
      <host name="alfa"/>
      <comment>Alfresco CIFS Server</comment>

      <!– Set to the broadcast mask for the subnet –>
      <broadcast>192.27.11.255</broadcast>
      <bindto>172.29.10.79</bindto>

      <!– Use Java socket based NetBIOS over TCP/IP and native SMB on linux –>
      <!–
      <tcpipSMB platforms="linux,solaris,macosx"/>
      <netBIOSSMB platforms="linux,solaris,macosx"/>
         –>
      <!– Can be mapped to non-privileged ports, then use firewall rules to forward
          requests from the standard ports –>
     
      <tcpipSMB port="1445" platforms="linux,solaris,macosx"/>
      <netBIOSSMB sessionPort="1139" namePort="1137" datagramPort="1138" platforms="linux,solaris,macosx"/>

      
      <hostAnnounce interval="5"/>

      <!– Use Win32 NetBIOS interface on Windows –>
      <Win32NetBIOS/>
      <Win32Announce interval="5"/>

<!–
      <WINS>
         <primary>1.2.3.4</primary>
         <secondary>5.6.7.8</secondary>
      </WINS>
–>
      <sessionDebug flags="Negotiate,Socket"/>
   </config>

Enfin un netstat me donne:
Microsoft Windows XP [version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\user>netstat -n

Connexions actives

  Proto  Adresse locale         Adresse distante       Etat
  TCP    127.0.0.1:1107         127.0.0.1:9535         ESTABLISHED
  TCP    127.0.0.1:1157         127.0.0.1:1158         ESTABLISHED
  TCP    127.0.0.1:1158         127.0.0.1:1157         ESTABLISHED
  TCP    127.0.0.1:1159         127.0.0.1:1160         ESTABLISHED
  TCP    127.0.0.1:1160         127.0.0.1:1159         ESTABLISHED
  TCP    127.0.0.1:9535         127.0.0.1:1107         ESTABLISHED
  TCP    172.29.10.79:1137      172.31.190.3:3128      CLOSE_WAIT
  TCP    172.29.10.79:1139      172.31.190.3:3128      CLOSE_WAIT
  TCP    172.29.10.79:1161      172.17.70.174:1352     ESTABLISHED
  TCP    172.29.10.79:1163      172.17.70.174:1533     ESTABLISHED
  TCP    172.29.10.79:1200      172.17.70.85:1352      ESTABLISHED
  TCP    172.29.10.79:1387      172.29.10.79:80        CLOSE_WAIT
  TCP    172.29.10.79:1465      172.31.190.3:3128      CLOSE_WAIT
  TCP    172.29.10.79:1538      172.31.190.3:3128      ESTABLISHED
  TCP    172.29.10.79:1539      172.31.190.3:3128      ESTABLISHED
  TCP    172.29.10.79:1540      172.29.0.182:135       TIME_WAIT
  TCP    172.29.10.79:1541      172.29.0.182:1026      ESTABLISHED
  TCP    172.29.10.79:1543      172.29.0.185:135       TIME_WAIT
  TCP    172.29.10.79:1544      172.29.0.185:1026      TIME_WAIT
  TCP    172.29.10.79:1545      172.29.0.182:389       TIME_WAIT
  TCP    172.29.10.79:1547      172.29.0.182:389       TIME_WAIT
  TCP    172.29.10.79:1548      172.29.0.182:139       TIME_WAIT

C:\Documents and Settings\user>

Quelqu'un aurait-il une idée ou une solution à mon problème, car j'avoue que je suis un peu perdu :? ?

Amicalement,

Stéph*

Outcomes