AnsweredAssumed Answered

Problema en la busqueda

Question asked by mercucho1 on Jul 7, 2011
Latest reply on Sep 9, 2011 by cmarguello
Hola! Estoy empezando a meter mano a alfresco y hay una cosilla que no logro hacer. Resulta que he creado un contenido personalizado, y a traves de la busqueda avanzada, me busca pero solo me lo encuentra si lo que escribo coincide al 100% con el contenido de la propiedad.

Por ejemplo, un campo en cuestión que se llama "resumen". Tengo un contenido cuyo valor resumen es "historia de una persona". Si busco "historia" (sin comillas) no me aparece resultados, si busco "persona" tampoco, pero si busco exactamente "historia de una persona" si que me aparece.

Os pongo el extracto del customModel.xml

            <property name="custom:inventarioResumen">
               <title>Resumen</title>
               <type>d:text</type>
               <mandatory>true</mandatory>
               <index enabled="true">
                  <atomic>true</atomic>
                  <stored>false</stored>
                  <tokenised>false</tokenised>
               </index>               
            </property>

y el del web-client-config-custom.xml
   <config evaluator="string-compare" condition="Advanced Search">
      <advanced-search>
         <custom-properties>
            <meta-data aspect="custom:inventario" property="custom:inventarioResumen" />
         </custom-properties>
      </advanced-search>
   </config>   

Le ha dado un monton de vueltas a las busquedas, pero no logro dar con la tecla. ¿Alguien podría orientarme un poco?

Outcomes