AnsweredAssumed Answered

CMIS CONTAINS() not finding documents as expected

Question asked by rmcveigh on Mar 14, 2011
Latest reply on Sep 21, 2011 by andy
I'm using 3.4 Enterprise.  Using the Share UI, I can search for the string "test" and find content nodes as expected.  I can use the advanced search scoped to a custom content type and still find instances of that type.  However, executing a CMIS search isn't finding the documents.  I've tried

select * from cmis:document where CONTAINS('test')

and

select * from my:type where CONTAINS('test')

and a bunch of other permutations and I can't figure out yet what the UI is doing differently to return the documents I expect where I haven't been able to mimic that behavior using a CMIS call.  What is different between the UI? 

I've also tried CONTAINS('TEXT:test') (not sure if that syntax is right) and no luck there either.  I get this exception when I try:

Caused by: org.alfresco.cmis.CMISQueryException: 02140674 Unknown column/property TEXT

I probably misread, but the docs for CMIS query lead me to believe this was possible.  I was reading here: http://wiki.alfresco.com/wiki/CMIS_Query_Language#Differences_between_cmis-strict_and_cmis-alfresco and following the link to the Alfresco FTS docs.

-Ryan

Outcomes