AnsweredAssumed Answered

cannot login anymore

Question asked by fluca1978 on Mar 14, 2011
Latest reply on Mar 15, 2011 by fluca1978
Hi all,
after experimenting with a (luckily test) environment 3.4.c on PostgreSQL I'm no more able to login. The system presents me the login web form but tells me that the remote server or my credentials are not valid. The backend is running and in the logs I found the following:


7:58:14,537 ERROR [org.springframework.web.context.ContextLoader] Context initialization failed 
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'file_prox\
y' defined in class path resource [alfresco/module/org_alfresco_module_dod5015/rm-action-context.\
xml]: Invocation of init method failed; nested exception is net.sf.acegisecurity.providers.Provid\
erNotFoundException: No authentication provider for net.sf.acegisecurity.providers.UsernamePasswo\
rdAuthenticationToken 
….
Caused by: net.sf.acegisecurity.providers.ProviderNotFoundException: No authentication provider f\
or net.sf.acegisecurity.providers.UsernamePasswordAuthenticationToken                            
        at net.sf.acegisecurity.providers.ProviderManager.doAuthentication(ProviderManager.java:1\
69)                                                                                              
        at net.sf.acegisecurity.AbstractAuthenticationManager.authenticate(AbstractAuthentication\
Manager.java:49)                                                                                 
        at net.sf.acegisecurity.intercept.AbstractSecurityInterceptor.beforeInvocation(AbstractSe\
curityInterceptor.java:372)                                                                      
        at net.sf.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor.invoke(Met\
hodSecurityInterceptor.java:77)                                                                  
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodI\
nvocation.java:172)                                                                              
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:20\
2)                                                                                               
        at $Proxy86.getName(Unknown Source)      

I'm pretty sure the only things I've changed in the configuration are the logging levels in the log4.properties and then restarted the alfresco service.
Any idea or hint to solve the problem?

Thanks

Outcomes