AnsweredAssumed Answered

Alfresco Data Query

Question asked by bensewell on Mar 25, 2011
Latest reply on Apr 4, 2011 by bensewell
Hi just doing some backup verification and noticed some small annonlymies with the data before and after backup.  There are no users logged into the system as its a local VM used for testing purposes.

All the other tables are an exact match.  These tables do match on the table sizes but just not on the number of records in the table.  I'm thinking that something must happen to these file automatically? 

My SQL script is as follows:

select table_name, table_rows, engine, data_length,data_free from information_schema.tables where information_schema.tables.table_schema = 'alfresco' INTO OUTFILE'/alf_data/Backup/tmp/MySQL_Prebackup.txt' FIELDS TERMINATED BY ',' ENCLOSED BY '"' LINES TERMINATED BY '\n';

Just doing a sanity check and the results of the table records are as follows:

Three figures all for the number of records. 

One before, one after percona backup but before prepare and one after prepare.  There has been no restore only the backup and prepare processes have been carried out.

alf_activity_feed   14   14   10
alf_node   3486   3701   3650
alf_node_properties   2119   1495   2119

When I tried this on our live environment with users in i had the following results:

alf_child_assoc   1331   1214   1411
alf_node   4387   4648   4406
alf_node_aspects   2104   2095   2224
alf_node_properties   3818   4052   4271
alf_transaction   677   571   677
jbpm_log   2275   1865   1861

This might be because users are using the system.

Just seems a bit weird that the table figures go up and down a bit.

Any ideas?

Outcomes