AnsweredAssumed Answered

Migración de Alfresco 3.0 a 4.0

Question asked by unknown-user on Jun 5, 2012
Latest reply on Jun 18, 2012 by unknown-user
Saludos,

He estado mirando el foro desde hace algunas semanas y me ha parecido muy útil. Por lo mismo, quisiera primero agradecerles y felicitarlos por todo el esfuerzo que han puesto y su voluntad para ayudar.

Los pongo un poco en contexto:

Se me ha encargado realizar en mi trabajo una migración de Alfresco Community 3.0 a la versión 4.0 (Community también). Hasta antes de este trabajo, desconocía completamente la herramienta, así que la wiki de Alfresco, este mismo foro y Google han sido mis mejores amigos. Mirando la documentación, sé que tengo que hacer primero una migración de 3.0 a 3.4, que es la que estoy tratando de hacer. Para ello, seguí los siguientes pasos:

1. Descargué alfresco.war y share.war de la página de Alfresco.
2. Renombré los war anteriores con la extensión .30 para no perderlos.
3. Revisé las librerías que tenía Alfresco.war y las comparé con las librerías en la versión 3.0, agregando las que no se encontraban.

Mi problema:

Trato de subir el servicio de Alfresco y se cae. Al revisar el log, me sale el siguiente error:

2012-06-05 12:57:48,516 INFO  [STDOUT] 12:57:48,499  ERROR [web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'LuceneFullTextSearchIndexer' defined in class path resource [alfresco/core-services-context.xml]: Cannot resolve reference to bean 'luceneFullTextSearchIndexer' while setting bean property 'target'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'luceneFullTextSearchIndexer' defined in class path resource [alfresco/core-services-context.xml]: Initialization of bean failed; nested exception is org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [cl.previred.liquidaciones.webscript.GenerateReport] for bean with name 'webscript.cl.birt.report.get' defined in file [/nueva-previred/alfresco-jboss/server/production/conf/alfresco/extension/web-scripts-application-context.xml]: problem with class file or dependent class; nested exception is java.lang.NoClassDefFoundError: org/alfresco/web/scripts/AbstractWebScript

Y de ahí para abajo es error, error, error.

Estoy tratando de hacer correr Alfresco en un CentOS 5.5, con base de datos PostgreSQL. Buscando en el foro, encontré una thread que sugería un problema relacionado con Spring Surf, así que bajé el jar y lo pegué en WEB-INF/lib, pero el error no ha cambiado.

¿Alguien podría ayudarme?

Outcomes