AnsweredAssumed Answered

[Résolu]Debuger avec eclipse configuration pas clair

Question asked by riogrande on May 13, 2009
Latest reply on May 18, 2009 by riogrande
Bonjour,

Je suis actuellement en train de lire "Alfresco Developer Guide" et je commence déjà à m'énerver au chapitre 2 avec des choses mal expliquées.

Config :
- Alfresco Lab 3 (3.0.0 (Stable 1526) )
- Sur tomcat et MySQL
- OS : Windows XP

Alors il est question de faire du débug avec Eclipse, pour cela il m'est dit dans le livre que je dois modifier certains truc :

1. Set the JPDA_TRANSPORT environment variable to dt_socket.

2. Set the JPDA_ADDRESS environment variable to 8000.

3. In Tomcat's startup script, change the line that invokes Catalina to include jpda. On Linux, this looks like:

exec "$PRGDIR"/"$EXECUTABLE" jpda start "$@"

4. Start Tomcat. You should see a message like "Listening for transport dt_socket at address: 8000".

Vous pouvez trouve le contenu complet sur cette page ci-dessous
http://www.troubleshootingwiki.org/Troubleshooting_Alfresco

Seul problème, ça n'explique pas où le faire… alors j'ai essayé de rajouter juste après "set JPDA="
set JPDA_TRANSPORT="dt_socket" 
set JPDA_ADDRESS="8000" 
dans le fichier tomcat\bin\catalina.bat => sans succès

J'ai rajouté dans le alfresco.bat => sans succès
j'ai crée 2 variables d'environnement (redémarré la machine) => sans succès

Sinon, la ligne "exec "$PRGDIR"/"$EXECUTABLE" jpda start "$@" " il faut aussi deviner où la mettre, mais j'ai trouvé l'information sur  cette page (tomcat\bin\startup.sh dernière ligne)

Bref, tous ces essais pour constater que "Listening for transport dt_socket at address: 8000" ne s'est jamais affiché au lancement d'Alfresco et que au moment de lancer le débugeur Eclipse j'ai l'erreur
Failed to connect to remote VM. Connection refused.
Connection refused: connect

Je commence à perdre patience cela fait 3h que je suis sur ce problème. J'ai fais quelque chose de faux où il manque une pierre à l'édifice  :?:

Outcomes