AnsweredAssumed Answered

Installazione alfresco3.2r2 su tomcat-6.0.18 on Debian

Question asked by frippe12573 on Mar 19, 2010
Latest reply on May 25, 2010 by joe.l3
Buona sera a tutti,
sono nuovo del forum e di alfresco in generale, sto cercando di installarlo sul mio server di lavoro,
ma ho dei problemi. Mi sono letto qualcosa in giro, ma i molti suggerimenti non mi hanno portato al successo.
Partendo dalla situazione 0, ho un server con debian lenny, un apache 2.2.9 funzionante e un mysql5.0.51,
java è una jdk scaricata dal sito sun  1.6.0_18. Come detto nel titolo tomcat è alla versione 6.0.18,
non è installato però tramite apt ma è parte del pacchetto di business intelligence che sto utilizzando
(per la precisione SpagoBI). Avrei optato di scaricare la versione di alfresco3.2r2war e di utilizzare i deploy,
in modo da utilizzare il tomcat esistente, senza per altro dover ammattire con varie istanze e configurazioni di utenti
e porte.
Sulla guida: http://www.openfacile.it/e107_plugins/content/content.php?content.23
un pò datata rispetto alle versioni che sto usando io, ho creato le varie directory mancanti sul mio tomcat
importando quelle necessarie (come descritto nella guida), successivamente ho fatto il deploy di
alfresco.war, share.war e mobile.war. Poi ho inserito il driver mysql che ho alla versione:
mysql-connector-java-5.1.7-bin.jar (la suddetta guida indicava mysql-connector-java-5.0.6-bin.jar), se accedo
con phpmysql al mysql vedo il db alfresco creato con lo script ma esso risulta vuoto, nessuna tabella, in information_schema
sono invece presenti 17 oggetti. (forse lo script non ha funzionato granchè?).
Premesso tutto questo, se mi loggo a http://mioserverip:8080/
arrivo alla pagina di managment di tomcat, in cui trovo share.war e mobile.war come processi avviati,
mentre alfresco (presente anch'esso) è fermo, se do lo start ottengo:
FAIL - Application at context path /alfresco could not be started

se vado sulla pagina: http://mioserverip:8080/alfresco ottengo:
HTTP Status 404 -
type Status report
message
description The requested resource () is not available.

alla pagina: http://mioserverip:8080/share ottengo:
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: org.alfresco.error.AlfrescoRuntimeException: 02190000 Unable to retrieve object: site-index of type: page
   org.alfresco.web.site.servlet.DispatcherServlet.service(DispatcherServlet.java:146)
   javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

org.alfresco.error.AlfrescoRuntimeException: 02190000 Unable to retrieve object: site-index of type: page
   org.alfresco.web.framework.ModelObjectManager.getObject(ModelObjectManager.java:140)
   org.alfresco.web.site.Model.getObject(Model.java:513)
   org.alfresco.web.site.Model.getPage(Model.java:165)
   org.alfresco.web.site.SlingshotPageMapper.executeMapper(SlingshotPageMapper.java:188)
   org.alfresco.web.site.AbstractPageMapper.execute(AbstractPageMapper.java:62)
   org.alfresco.web.site.DefaultRequestContextFactory.newInstance(DefaultRequestContextFactory.java:109)
   org.alfresco.web.site.FrameworkHelper.initRequestContext(FrameworkHelper.java:202)
   org.alfresco.web.site.servlet.DispatcherServlet.service(DispatcherServlet.java:142)
   javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

org.alfresco.web.framework.exception.ModelObjectPersisterException: Error loading object id: site-index from persister id: RemoteStore_alfresco/site-data/pages_page
   org.alfresco.web.framework.MultiModelObjectPersister.getObject(MultiModelObjectPersister.java:110)
   org.alfresco.web.framework.ModelObjectManager.getObject(ModelObjectManager.java:136)
   org.alfresco.web.site.Model.getObject(Model.java:513)
   org.alfresco.web.site.Model.getPage(Model.java:165)
   org.alfresco.web.site.SlingshotPageMapper.executeMapper(SlingshotPageMapper.java:188)
   org.alfresco.web.site.AbstractPageMapper.execute(AbstractPageMapper.java:62)
   org.alfresco.web.site.DefaultRequestContextFactory.newInstance(DefaultRequestContextFactory.java:109)
   org.alfresco.web.site.FrameworkHelper.initRequestContext(FrameworkHelper.java:202)
   org.alfresco.web.site.servlet.DispatcherServlet.service(DispatcherServlet.java:142)
   javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

org.alfresco.web.framework.exception.ModelObjectPersisterException: Failure to load model object for path: site-index.xml
   org.alfresco.web.framework.StoreModelObjectPersister.getObjectByPath(StoreModelObjectPersister.java:170)
   org.alfresco.web.framework.StoreModelObjectPersister.getObject(StoreModelObjectPersister.java:108)
   org.alfresco.web.framework.MultiModelObjectPersister.getObject(MultiModelObjectPersister.java:106)
   org.alfresco.web.framework.ModelObjectManager.getObject(ModelObjectManager.java:136)
   org.alfresco.web.site.Model.getObject(Model.java:513)
   org.alfresco.web.site.Model.getPage(Model.java:165)
   org.alfresco.web.site.SlingshotPageMapper.executeMapper(SlingshotPageMapper.java:188)
   org.alfresco.web.site.AbstractPageMapper.execute(AbstractPageMapper.java:62)
   org.alfresco.web.site.DefaultRequestContextFactory.newInstance(DefaultRequestContextFactory.java:109)
   org.alfresco.web.site.FrameworkHelper.initRequestContext(FrameworkHelper.java:202)
   org.alfresco.web.site.servlet.DispatcherServlet.service(DispatcherServlet.java:142)
   javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

java.io.IOException: Unable to test document path: site-index.xml in remote store: alfresco due to error: 404
   org.alfresco.web.scripts.RemoteStore.hasDocument(RemoteStore.java:351)
   org.alfresco.web.framework.StoreModelObjectPersister.getObjectByPath(StoreModelObjectPersister.java:136)
   org.alfresco.web.framework.StoreModelObjectPersister.getObject(StoreModelObjectPersister.java:108)
   org.alfresco.web.framework.MultiModelObjectPersister.getObject(MultiModelObjectPersister.java:106)
   org.alfresco.web.framework.ModelObjectManager.getObject(ModelObjectManager.java:136)
   org.alfresco.web.site.Model.getObject(Model.java:513)
   org.alfresco.web.site.Model.getPage(Model.java:165)
   org.alfresco.web.site.SlingshotPageMapper.executeMapper(SlingshotPageMapper.java:188)
   org.alfresco.web.site.AbstractPageMapper.execute(AbstractPageMapper.java:62)
   org.alfresco.web.site.DefaultRequestContextFactory.newInstance(DefaultRequestContextFactory.java:109)
   org.alfresco.web.site.FrameworkHelper.initRequestContext(FrameworkHelper.java:202)
   org.alfresco.web.site.servlet.DispatcherServlet.service(DispatcherServlet.java:142)
   javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.

Mentre alla pagina: http://mioserverip:8080/mobile ottengo
la schermata con i campi user e password, ma con (admin/admin)
non mi loggo.

A questo punto non so, il post è lungo, ma ho cercato di dare tutti i dettagli della sitazione…
spero siano sufficienti a qualcuno di voi per darmi qualche dritta….

A presto
F.

Outcomes