AnsweredAssumed Answered

Problème surcharge repository.properties

Question asked by bub on Jul 2, 2009
Latest reply on Jul 2, 2009 by bub
Bonjour,

J'ai déjà installé Alfresco pour tester sur une RedHat4 32bits avec Tomcat 5. Installation réussie après quelques recherches…

Aujourd'hui, on me demande de tester Alfresco sur une RedHat5 64Bits avec Tomcat6…
J'en ai presque terminé, à part que le fait de modifier mon fichier custom-repository.properties, ne surcharge pas le fichier original.
Mon instance tomcat est installé sur /var/tomcat/instances/alfresco
J'ai donc créé le répertoire /var/tomcat/instances/alfresco/shared/classes
J'ai ensuite copier le repertoire extension et je me retrouve donc avec
/var/tomcat/instances/alfresco/shared/classes/alfresco/extension/ dans lequel, je modifie mon fichier custom.
Oui mais voila, malgré la modification, alfresco continue de me créé le root.dir sous ./alf_data  :cry:
Il en va de meme pour les appli telles que swftool et ImageMagick
Fichier custom-repository.properties :

###############################
## Common Alfresco Properties #
###############################

#
# Sample custom content and index data location
#
dir.root=/alfresco

# External executable locations
ooo.exe=soffice
ooo.user=${dir.root}/oouser
img.root=/usr
img.dyn=${img.root}/lib
img.exe=${img.root}/bin/convert
swf.exe=/usr/bin/pdf2swf

#
# Sample database connection properties
#
#db.username=alfresco
#db.password=alfresco
#db.pool.initial=10
#db.pool.max=100

#
# Activate index tracking and recovery
#
#index.tracking.cronExpression=0/5 * * * * ?
#index.recovery.mode=AUTO

#
# Property to control whether schema updates are performed automatically.
# Updates must be enabled during upgrades as, apart from the static upgrade scripts,
# there are also auto-generated update scripts that will need to be executed.  After
# upgrading to a new version, this can be disabled.
#
#db.schema.update=true

#
# Derby connection
#
#db.driver=org.apache.derby.jdbc.EmbeddedDriver
#db.url=jdbc:derby:/srv/alfresco/alf_data/derby_data/alfresco;create=true

#
# MySQL connection
#
#db.driver=org.gjt.mm.mysql.Driver
#db.url=jdbc:mysql://localhost/alfresco
db.driver=com.mysql.jdbc.Driver
db.url=jdbc:mysql://localhost/alfresco

#
# Oracle connection
#
#db.driver=oracle.jdbc.OracleDriver
#db.url=jdbc:oracle:thin:@localhost:1521:alfresco

#
# SQLServer connection (note you must enable TCP protocol on fixed port 1433)
#
#db.driver=com.microsoft.sqlserver.jdbc.SQLServerDriver
#db.url=jdbc:sqlserver://localhost:1433;databaseName=alfresco
#db.txn.isolation=4096

# The well known RMI registry port is defined in the alfresco-shared.properties file
# alfresco.rmi.services.port=50500
#
# RMI service ports for the individual services.
# These six services are available remotely.
#
# Assign individual ports for each service for best performance
# or run several services on the same port. You can even run everything on 50500 if needed.
#
# Select 0 to use a random unused port.
#
#avm.rmi.service.port=50501
#avmsync.rmi.service.port=50502
#attribute.rmi.service.port=50503
#authentication.rmi.service.port=50504
#repo.rmi.service.port=50505
#action.rmi.service.port=50506

Mes variables d'environnement sont les suivantes :
CATALINA_BASE=/var/tomcat/instances/alfresco
CATALINA_HOME=/opt/tomcat/6.0.14
TOMCAT_HOME=/opt/tomcat/6.0.14
JAVA_HOME=/usr/java/jdk1.6.0_14/

voici le log de démarrage….


2 juil. 2009 08:18:43 org.apache.catalina.core.AprLifecycleListener init
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/jdk1.6.0_14/jre/lib/amd64/server:/usr/java/jdk1.6.0_14/jre/lib/amd64:/usr/java/jdk1.6.0_14/jre/../lib/amd64:/usr/java/packages/lib/amd64:/lib:/usr/lib
2 juil. 2009 08:18:43 org.apache.coyote.http11.Http11Protocol init
INFO: Initialisation de Coyote HTTP/1.1 sur http-8081
2 juil. 2009 08:18:43 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 744 ms
2 juil. 2009 08:18:43 org.apache.catalina.core.StandardService start
INFO: Démarrage du service Catalina
2 juil. 2009 08:18:43 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.14
2 juil. 2009 08:18:43 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive alfresco.war de l'application web
08:19:01,835  ERROR [transform.magick.AbstractImageMagickContentTransformer] ImageMagickContentTransformer not available: Failed to perform ImageMagick transformation:
Execution result:
   os:         Linux
   command:    [./ImageMagick/bin/convert, /var/tomcat/instances/alfresco/temp/Alfresco/ImageMagickContentTransformer_init_source_651478509087420791.gif, /var/tomcat/instances/alfresco/temp/Alfresco/ImageMagickContentTransformer_init_target_3221398898843004056.png]
   succeeded:  false
   exit code:  1
   out:
   err:        Cannot run program "./ImageMagick/bin/convert": java.io.IOException: error=2, No such file or directory
08:19:04,767  INFO  [config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
08:19:09,389  ERROR [content.transform.RuntimeExecutableContentTransformer] Failed to start a runtime executable content transformer:
Execution result:
   os:         Linux
   command:    [./bin/pdf2swf, -V]
   succeeded:  false
   exit code:  1
   out:
   err:        Cannot run program "./bin/pdf2swf": java.io.IOException: error=2, No such file or directory
08:19:18,190  INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
08:19:18,275  INFO  [domain.schema.SchemaBootstrap] Exécution du script de base de données /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaCreate-org.hibernate.dialect.MySQLInnoDBDialect-9120378209631447505.sql (généré)
08:19:26,083  INFO  [domain.schema.SchemaBootstrap] Exécution du script de base de données /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-8245154009810816585.sql (copié depuis classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-MappedFKIndexes.sql)
08:19:26,091  INFO  [domain.schema.SchemaBootstrap] Exécution du script de base de données /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-5515439457652896020.sql (copié depuis classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/AlfrescoPostCreate-2.2-Extra.sql)
08:19:26,900  INFO  [domain.schema.SchemaBootstrap] Exécution du script de base de données /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-3850153688711715690.sql (copié depuis classpath:alfresco/dbscripts/create/2.2/org.hibernate.dialect.MySQLInnoDBDialect/post-create-indexes-04.sql)
08:19:26,940  INFO  [domain.schema.SchemaBootstrap] Exécution du script de base de données /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaUpdate-org.hibernate.dialect.MySQLInnoDBDialect-2430551992288335083.sql (copié depuis classpath:alfresco/dbscripts/create/3.0/org.hibernate.dialect.MySQLInnoDBDialect/create-activities-extras.sql)
08:19:27,217  INFO  [domain.schema.SchemaBootstrap] Tous les instructions exécutées sont journalisées dans le fichier /var/tomcat/instances/alfresco/temp/Alfresco/AlfrescoSchemaUpdate-All_Statements-1943722393707850097.sql.
08:20:07,515 User:System WARN  [repo.admin.ConfigurationChecker] The Alfresco 'dir.root' property is set to a relative path './alf_data'.  'dir.root' should be overridden to point to a specific folder.
08:20:07,515 User:System INFO  [repo.admin.ConfigurationChecker] Le répertoire racine de données d'Alfresco ('dir.root') est : ./alf_data
08:20:07,586 User:System INFO  [admin.patch.PatchExecuter] Vérification des correctifs à appliquer …
08:20:08,830 User:System INFO  [admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.db-V3.0-0-CreateActivitiesExtras
RESULT:
Script completed
=====================================
08:20:08,840 User:System INFO  [repo.module.ModuleServiceImpl] 0 module(s) trouvé(s).
08:20:14,066 User:System ERROR [alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
08:20:14,066 User:System ERROR [alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
08:20:14,745 User:System WARN  [alfresco.util.OpenOfficeConnectionTester] La connexion à OpenOffice n'a pu être établie.
08:20:14,837 User:System INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_14-b08; maximum heap size 999,000MB
08:20:14,839 User:System INFO  [service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (Stable 1526) schema 1002 - Installed version 3.0.0 (Stable 1526) schema 1002
2 juil. 2009 08:20:42 org.apache.coyote.http11.Http11Protocol start
INFO: Démarrage de Coyote HTTP/1.1 sur http-8081
2 juil. 2009 08:20:42 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8010
2 juil. 2009 08:20:42 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=1/54  config=null
2 juil. 2009 08:20:43 org.apache.catalina.startup.Catalina start
INFO: Server startup in 119578 ms

Je tiens à préciser qu'alfresco s'affiche dans mon navigateur, mais sa config me pose problème…

Merci de votre aide.

Outcomes