AnsweredAssumed Answered

Audit

Question asked by fagiano on Aug 4, 2010
Latest reply on Aug 4, 2010 by fagiano
Sono riuscito a far andare show_audit.ftl ma quando va questo non mi va più il workflow ho fatto i seguenti passi su alfresco 3.3

Copiare i file auditConfig.xml e audit-services-context.xml, che si trovano in E:\Alfresco\tomcat\webapps\alfresco\WEB-INF\classes\alfresco, nel seguente percorso E:\Alfresco\tomcat\shared\classes\alfresco\extension.

Aprire il file auditConfig.xml, appena inserito nella cartella extension, e sostituire enable=”false” con enable =”true” in modo da visualizzare quanto segue
<Audit xmlns="http://www.alfresco.org/model/audit/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" enabled="true" auditInternal="false" mode="all">.
Poi inserire il metodo getSevice come segue

<!– The File/Folder Service –>
   
    <Service name="FileFolderService" mode="none">
        <Method name="rename" mode="all"/>
        <Method name="move" mode="all"/>
        <Method name="copy" mode="all" auditInternal="true"/>
        <Method name="create" mode="all"/>
        <Method name="delete" mode="all"/>
        <Method name="makeFolders" mode="all"/>
        <Method name="getWriter" mode="all"/>

       <Method name="getReader" mode="all"/>
    </Service>
   
    <Service name="ContentService" mode="none">
        <Method name="getWriter" mode="all"/>
        <Method name="transform" mode="all"/>

        <Method name="getReader" mode="all"/>
    </Service>

Infine su global property non ho aggiunto niente

Outcomes