AnsweredAssumed Answered

[Résolu] Problème installation DoCASU pour community 3.2

Question asked by felie on Aug 24, 2009
Latest reply on Aug 24, 2009 by felie
Bien qu'ayant, semble t'il, correctement suivi la procédure d'installation de DoCASU (version 1.6.2) pour Alfresco 3.x http://code.optaros.com/trac/docasu/wiki/Installation, je rencontre d'une erreur lors de l'installation sous Alfresco 3.2 :

lenny:/opt/Alfresco# ./apply_amps.sh
./apply_amps.sh: line 7: /usr/lib/jvm/java-6-sun-1.6.0.12/bin: is a directory
This script will apply all the AMPs in ./amps to the alfresco.war file in /opt/Alfresco/tomcat/webapps
Press control-c to stop this script . . .
Press any other key to continue . . .
Exception in thread "main" java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass(libgcj.so.90)
   at org.alfresco.repo.module.tool.ModuleManagementTool.<clinit>(ModuleManagementTool.java:90)
   at java.lang.Class.initializeClass(libgcj.so.90)
   at java.lang.reflect.Method.invoke(libgcj.so.90)
   at com.simontuffs.onejar.Boot.run(Boot.java:287)
   at com.simontuffs.onejar.Boot.main(Boot.java:137)
Caused by: java.util.MissingResourceException: Bundle de.schlichtherle.io.DefaultRaesZipDetector not found for locale fr_FR by classloader gnu.gcj.runtime.SystemClassLoader{urls=[file:bin/alfresco-mmt.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.util.ResourceBundle.getBundle(libgcj.so.90)
   at java.util.ResourceBundle.getBundle(libgcj.so.90)
   at java.util.logging.Logger.<init>(libgcj.so.90)
   at java.util.logging.Logger.getLogger(libgcj.so.90)
   at de.schlichtherle.io.DefaultRaesZipDetector.<clinit>(Unknown Source)
   at java.lang.Class.initializeClass(libgcj.so.90)
   …5 more
Exception in thread "main" java.lang.ExceptionInInitializerError
   at java.lang.Class.initializeClass(libgcj.so.90)
   at org.alfresco.repo.module.tool.ModuleManagementTool.<clinit>(ModuleManagementTool.java:90)
   at java.lang.Class.initializeClass(libgcj.so.90)
   at java.lang.reflect.Method.invoke(libgcj.so.90)
   at com.simontuffs.onejar.Boot.run(Boot.java:287)
   at com.simontuffs.onejar.Boot.main(Boot.java:137)
Caused by: java.util.MissingResourceException: Bundle de.schlichtherle.io.DefaultRaesZipDetector not found for locale fr_FR by classloader gnu.gcj.runtime.SystemClassLoader{urls=[file:bin/alfresco-mmt.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.util.ResourceBundle.getBundle(libgcj.so.90)
   at java.util.ResourceBundle.getBundle(libgcj.so.90)
   at java.util.logging.Logger.<init>(libgcj.so.90)
   at java.util.logging.Logger.getLogger(libgcj.so.90)
   at de.schlichtherle.io.DefaultRaesZipDetector.<clinit>(Unknown Source)
   at java.lang.Class.initializeClass(libgcj.so.90)
   …5 more
About to clean out tomcat/webapps/alfresco directory and temporary files…
Press control-c to stop this script . . .
Press any other key to continue . . .
Cleaning temporary Alfresco files from Tomcat…

Auriez-vous une idée de la cause ?

  F.

    OS: debian 5.0
    openOffice : 3.1.0-11
    swftools : 0.9.0
    Mysql : 5.0.51a-24+lenny1
    jdk : sun-java6-jdk, version 6-12-1
    Alfresco version: 3.2.0 (2039)
    pack français : alfresco_3.2_FR.zip

Outcomes