AnsweredAssumed Answered

Alfresco Community 3.2 et Active Directory sur Ubuntu

Question asked by dflasse on Aug 26, 2009
Latest reply on Sep 3, 2009 by dflasse
J'ai installé sans souci Alfresco 3.2 sur un Ubuntu 9.04 en utilisant le repository 'partners'. Il fonctionne parfaitement tant que j'utilise l'authentification interne à Alfresco (AlfrescoNtlm).

J'ai besoin d'un SSO pour mes utilisateurs sur le serveur AD win2k3. J'ai donc suivi les instructions (cryptiques àmon sens) du wiki et j'ai configuré le Subsystem LDAP-AD  pour qu'il synchronise les utilisateurs. D'après les logs, Alfresco lit bien les users (je suppose qu'il stocke une copie locale).

J'ai modifié l'authentication chain comme ceci:

authentication.chain=alfrescoNtlm1:alfrescoNtlm,passthru1:passthru,ldap-ad1:ldap-ad

et le passthru ressemble à ceci:

passthru.authentication.useLocalServer=false
passthru.authentication.domain=
passthru.authentication.servers=DOMAINE\\xx.xx.xx.xx,xx.xx.xx.xx
passthru.authentication.guestAccess=false
passthru.authentication.defaultAdministratorUserNames=administrator
#Timeout value when opening a session to an authentication server, in milliseconds
passthru.authentication.connectTimeout=5000
#Offline server check interval in seconds
passthru.authentication.offlineCheckInterval=300
passthru.authentication.protocolOrder=TCPIP,NetBIOS
passthru.authentication.authenticateCIFS=true
passthru.authentication.authenticateFTP=true

Lorsque j'essaie de me connecter, je vois bien passer dans les log un requête Ntlm (d'abord v1, puis v2) mais l'authentification ne fonctionne pas et j'ai un time out après plusieurs dizaines de secondes.

Outcomes