AnsweredAssumed Answered

Errore invio Inviti da sito

Question asked by stefanomior on Jun 9, 2011
Latest reply on Jul 7, 2011 by openpj
Buongiorno, ho installato alfresco ver.3.4, e sto provando ad utilizzarlo, ho creato un sito, ma quando provo ad inviare inviti, ricevo sempre "0 inviti inviati - 1 Errore". Premetto che dopo aver letto il WIKI di alfresco sulla configurazione del SMTP ho inserito le seguenti istruzioni alla fine del file C:\Alfresco\tomcat\shared\classes\alfresco-global.properties

### e-mail settings
mail.host=smtps.aruba.it
mail.port=465
mail.protocol=smtps
mail.username=info@5glflex.com
mail.password=xxxxxxxxxx

# New Properties
mail.smtps.starttls.enable=true
mail.smtps.auth=true

e aggiunto il file C:\Alfresco\tomcat\shared\classes\alfresco\extension\custom-email-context.xml allinterno del quale ho inserito il seguente testo:

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
<!–                        –>
<!– MAIL SERVICE           –>
<!–                        –>

<bean id="mailService" class="org.springframework.mail.javamail.JavaMailSenderImpl">
    <property name="host">
        <value>${mail.host}</value>
    </property>
    <property name="port">
        <value>${mail.port}</value>
    </property>
    <property name="protocol">
        <value>${mail.protocol}</value>
    </property>
    <property name="username">
        <value>${mail.username}</value>
    </property>
    <property name="password">
        <value>${mail.password}</value>
    </property>
    <property name="defaultEncoding">
        <value>${mail.encoding}</value>
    </property>
    <property name="javaMailProperties">
        <props>
            <prop key="mail.smtps.auth">${mail.smtps.auth}</prop>
            <prop key="mail.smtps.starttls.enable">${mail.smtps.starttls.enable}</prop>
        </props>
    </property>
</bean>
</beans>

Inoltre sul server che ospita alfresco, ho installato outlook con l'account sopra riportato e funziona correttamente.

Quale può essere il problema nell'inviare gli inviti?

Grazie in anticipo
Stefano

Outcomes