AnsweredAssumed Answered

exempleModel.xml windows 2003 ok Linux rhel 5.3 ko

Question asked by fabio79 on Sep 4, 2009
Bonjour voici mon installation,

Alfresco 3.2
Mysql 5.1
jdk 1.6
Linux rhel 5.3

j'ai un problème concernant l'ajout d'un modèle personnalisé sur Linux

Les 4 fichiers ci-dessous fonctionnent parfaitement si je les utilise avec un serveur windows 2003
monmodelModel.xml
monmodel-model-context.xml
web-client-config-custom
webclient.properties

Mon installation sous Linux m'indique deux erreurs:
17:44:00,813 ERROR [org.alfresco.fileserver] Failed to get local domain/workgroup name, using default of WORKGROUP
17:44:00,814 ERROR [org.alfresco.fileserver] (This may be due to firewall settings or incorrect <broadcast> setting)

néanmoins les utilisateurs peuvent s'authentifier par le biais de l'active directory et utiliser alfresco sans problème (sauf CIFS mais ce n'est pas le sujet)

Lorsque je veux utiliser le sample exempleModel.xml, ajouter un model personnalisé testé et fonctionnel sur windows 2003 sur Linux cela ne fonctionne pas… :!:

Lorsque je clique par exemple sur recherche avancée j'ai un "System Error"
javax.faces.FacesException: java.lang.NullPointerException
caused by:
org.apache.jasper.JasperException: java.lang.NullPointerException
caused by:
java.lang.NullPointerException

et dans le fichier alfresco.log
17:47:27,963 DEBUG [org.alfresco.smb.protocol.auth] Protocol order primary=TCP/IP NetBIOS, secondary=Native SMB (port 445)
17:47:27,966 DEBUG [org.alfresco.smb.protocol.auth] Using offline check interval of 300 seconds
17:47:28,013 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Authentication' subsystem, ID: [managed, passthru1] complete
17:56:04,076 DEBUG [org.alfresco.smb.protocol.auth] NT Session setup NTLMSSP, MID=8, UID=0, PID=65279
17:56:04,077 DEBUG [org.alfresco.smb.protocol.auth] Using Write transaction
17:56:04,091 DEBUG [org.alfresco.smb.protocol.auth] Kerberos AP-REQ - [AP-REQ:APOptions=MutualAuth ,Ticket=Len=1098,Authenticator=EncType=3,Kvno=-1,Len=168]
17:56:04,093 DEBUG [org.alfresco.smb.protocol.auth] Kerberos mutual auth required, parsing AP-REQ
17:56:04,094 ERROR [org.alfresco.smb.protocol.auth] Kerberos logon error
17:56:04,094 ERROR [org.alfresco.smb.protocol.auth] java.lang.NullPointerException

Si quelqu'un peut m'indiquer par ou attaquer mon problème, se serait merveilleux…
Merci

Outcomes