AnsweredAssumed Answered

Problem with workflow assignee

Question asked by jabelleira on May 26, 2011
Latest reply on Jul 7, 2011 by jonvargas
Hi everyone

We have a big problem using workflows, and we have searched the web and it seems nobody has the same problem.


We are using Alfresco Community 3.4d and when the user interface for a task, where user has to choose someone to continue with it, is rendered; the buton used to assigne does not work at all, it does not show me and does not let me choose the users that i have created in Alfresco, it simply does nothing :evil: .

this is the task code in de model
    <type name="mwf:submitApproveContent">
         <parent>bpm:startTask</parent>
         <mandatory-aspects>
            <aspect>bpm:assignee</aspect>         
         </mandatory-aspects> 
    </type>

this is the code inside the process definition
     <swimlane name="initiator"/>

   <start-state name="start">
      <task name="mwf:submitApproveContent" swimlane="initiator"/>         
      <transition to="review"></transition>
   </start-state>

and this is the corresponding config in the web-client-config-custom.xml
    <config evaluator="node-type" condition="mwf:submitApproveContent" replace="true">
      <property-sheet>
         <separator name="sep1" display-label-id="general" component-generator="HeaderSeparatorGenerator" />
         <show-property name="bpm:workflowDescription" component-generator="TextAreaGenerator" />
         <show-property name="bpm:workflowPriority" display-label-id="wf_review_priority" />
         <show-property name="bpm:workflowDueDate" display-label-id="wf_review_due_date" />
         <separator name="sep2" display-label-id="users_and_roles" component-generator="HeaderSeparatorGenerator" />
         <show-association name="bpm:assignee" display-label-id="wf_reviewer" />
      </property-sheet>
   </config>

Thanks in advance

Outcomes