AnsweredAssumed Answered

Alfresco Web editor not working

Question asked by patni123 on May 31, 2011
Hi,

Alfresco version 3.3.

We were not able to make Alfresco Web Editor feature working on our server.
We tried to follow steps mentioned in Forum from link  http://wiki.alfresco.com/wiki/Web_Editor
and trying to open the sample application (customer.war) in browser. We can see the jsp page is coming after hitting  http://localhost:8080/customer/index.jsp.

After clicking on specified link , we are getting error page as below:-

HTTP status 404 - /awe/page/metadata.

It seems there is some configuration missing. Please help us to get this solved.

Steps followed below:-

1. Added the jars as mentioned in Alfresco Wiki web editor.
2. Added new xml(awe-config-custom.xml) in shared/classes/alfresco/web-extension with below content replacing MYSERVER and PORT

<?xml version="1.0" encoding="UTF-8"?>
<alfresco-config>
<plug-ins>
<element-readers>
<element-reader element-name="remote" class="org.springframework.extensions.config.RemoteConfigElementReader" />
</element-readers>
</plug-ins>

<config evaluator="string-compare" condition="Remote">
<remote>
<endpoint>
<id>alfresco</id>
<name>Alfresco - user access</name>
<description>Access to Alfresco Repository WebScripts that require user authentication</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://MYSERVER:MYPORT/alfresco/s
</endpoint-url>
<identity>user</identity>
</endpoint>
</remote>
</config>
</alfresco-config>

3. Changed web.xml filter to below. Changed the context path to /customer

<filter>
<filter-name>Alfresco Web Editor Filter</filter-name>
<description>Enables support for the Alfresco Web Editor</description>
<filter-class>org.alfresco.web.awe.filter.WebEditorFilter</filter-class>
<init-param>
<param-name>contextPath</param-name>
<param-value>/customer</param-value>
</init-param>
</filter>

<filter-mapping>
<filter-name>Alfresco Web Editor Filter</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

4. Added start template, mark content, end template tags in index.jsp with form id.
5. Node reference created in alfresco was provided in noderefs.jsp.



Regards,
Patni Alfresco Team

Outcomes