AnsweredAssumed Answered

Jboss deployment issues

Question asked by iaina on Jun 28, 2005
Starting with a clean install as prescribed, the following jboss deployment issues were encountered.



ault/tmp/deploy/tmp17608web-client.ear-contents/web-client-exp.war/ deployment f

ailed

at org.jboss.web.tomcat.tc5.TomcatDeployer.performDeployInternal(TomcatD

eployer.java:356)

at org.jboss.web.tomcat.tc5.TomcatDeployer.performDeploy(TomcatDeployer.

java:91)

at org.jboss.web.AbstractWebDeployer.start(AbstractWebDeployer.java:357)

at org.jboss.web.WebModule.startModule(WebModule.java:68)

at org.jboss.web.WebModule.startService(WebModule.java:46)

at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanS

upport.java:272)

[cut]

at org.jboss.Main$1.run(Main.java:463)

at java.lang.Thread.run(Unknown Source)

00:04:24,541 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

— Incompletely deployed packages —

org.jboss.deployment.DeploymentInfo@fa9a6542 { url=file:/C:/alfresco/jboss/serve

r/default/deploy/web-client.ear }

deployer: org.jboss.deployment.EARDeployer@3a9d95

status: Deployment FAILED reason: URL file:/C:/alfresco/jboss/server/default/t

mp/deploy/tmp17608web-client.ear-contents/web-client-exp.war/ deployment failed

state: FAILED

watch: file:/C:/alfresco/jboss/server/default/deploy/web-client.ear

altDD: null

lastDeployed: 1119913459143

lastModified: 1119913448598

mbeans:

— MBeans waiting for other MBeans —

ObjectName: jboss.web.deployment:id=-1124426415,war=web-client.war

State: FAILED

Reason: org.jboss.deployment.DeploymentException: URL file:/C:/alfresco/jboss/

server/default/tmp/deploy/tmp17608web-client.ear-contents/web-client-exp.war/ de

ployment failed

— MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM —

ObjectName: jboss.web.deployment:id=-1124426415,war=web-client.war

State: FAILED

Reason: org.jboss.deployment.DeploymentException: URL file:/C:/alfresco/jboss/

server/default/tmp/deploy/tmp17608web-client.ear-contents/web-client-exp.war/ de

ployment failed



00:04:24,791 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-808

0

00:04:25,162 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009

00:04:26,443 INFO [JkMain] Jk running ID=0 time=0/1482 config=null

00:04:26,453 INFO [Server] JBoss (MX MicroKernel) [4.0.2 (build: CVSTag=JBoss_4

_0_2 date=200505022023)] Started in 1m:22s:708ms

00:05:20,521 INFO [STDOUT] Initializing web-app from stream with InputStream.

00:05:22,304 INFO [STDOUT] WURFL has been initialized

==============================================

The portal server was accessible and admin user could login, but the alf ui was inaccessible

Outcomes