AnsweredAssumed Answered

Google Docs configuration for 3.4.d?

Question asked by bgergens on Jun 24, 2011
Latest reply on Jul 1, 2011 by bgergens
I've been trying to set up Google Docs on my test installation of 3.4.d community and I must be doing something wrong, but I can't seem to figure out what. When I try to check out a document - any document - to Google Docs, it does show up in my master Google Docs user account. The master account remains owner of the file, and "Can Edit" permission is granted to only admin@alfresco.com. I'm not sure why this is happening, since I was under the impression it should grant access to whomever has access to the file. My user account is presently the only one with an associated Google username, but the checked-out files never appear to be associated with my username.

First, I added an account to my Google Apps domain to act as the master account from which all sharing would occur.
Then I added the following three options to alfresco-global.properties:

googledocs.googleeditable.enabled=true
googledocs.username=theusername
googledocs.password=thepassword

And here is my share-config-custom.xml:


<alfresco-config>
  
   <!– Repository Library config section –>
   <config evaluator="string-compare" condition="RepositoryLibrary" replace="true">
      <!–
         Whether the link to the Repository Library appears in the header component or not.
      –>
      <visible>true</visible>
   </config>

   <config evaluator="string-compare" condition="Remote">
      <remote>
         <endpoint>
            <id>alfresco-noauth</id>
            <name>Alfresco - unauthenticated access</name>
            <description>Access to Alfresco Repository WebScripts that do not require authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://localhost:8080/alfresco/s</endpoint-url>
            <identity>none</identity>
         </endpoint>

         <endpoint>
            <id>alfresco</id>
            <name>Alfresco - user access</name>
            <description>Access to Alfresco Repository WebScripts that require user authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://localhost:8080/alfresco/s</endpoint-url>
            <identity>user</identity>
         </endpoint>

         <endpoint>
            <id>alfresco-feed</id>
            <name>Alfresco Feed</name>
            <description>Alfresco Feed - supports basic HTTP authentication via the EndPointProxyServlet</description>
            <connector-id>http</connector-id>
            <endpoint-url>http://localhost:8080/alfresco/s</endpoint-url>
            <basic-auth>true</basic-auth>
            <identity>user</identity>
         </endpoint>
      </remote>
   </config>
  
   <!– Document Library config section –>
   <config evaluator="string-compare" condition="DocumentLibrary" replace="true">
   
     <aspects>
            <!– Aspects that a user can see –>
            <visible>
               <aspect name="cm:generalclassifiable" />
               <aspect name="cm:complianceable" />
               <aspect name="cm:dublincore" />
               <aspect name="cm:effectivity" />
               <aspect name="cm:summarizable" />
               <aspect name="cm:versionable" />
               <aspect name="cm:templatable" />
               <aspect name="cm:emailed" />
               <aspect name="emailserver:aliasable" />
               <aspect name="cm:taggable" />
               <aspect name="app:inlineeditable" />
               <aspect name="gd:googleEditable" />
               <aspect name="cm:geographic" />
               <aspect name="exif:exif" />
            </visible>
   
            <!– Aspects that a user can add. Same as "visible" if left empty –>
            <addable>
            </addable>
   
            <!– Aspects that a user can remove. Same as "visible" if left empty –>
            <removeable>
            </removeable>
         </aspects>
   
         <google-docs>
            <!–
               Enable/disable the Google Docs UI integration (Extra types on Create Content menu, Google Docs actions).
            –>
            <enabled>true</enabled>
   
            <!–
               The mimetypes of documents Google Docs allows you to create via the Share interface.
               The I18N label is created from the "type" attribute, e.g. google-docs.doc=Google Docs&trade; Document
            –>
            <creatable-types>
               <creatable type="doc">application/msword</creatable>
               <creatable type="xls">application/vnd.ms-excel</creatable>
               <creatable type="ppt">application/vnd.ms-powerpoint</creatable>
            </creatable-types>
         </google-docs>
   
   </config>

</alfresco-config>

Again, the result of a checkout is that the file appears in the master account, but the only other user with access is admin@alfresco.com, and I'm not even sure where that's coming from. I thought it might be a result of the fact that the first file I tried to access was owned by admin, but I've since tried it with several other files that I uploaded with my own user account and the result is the same.

I tried adding
log4j.logger.org.alfresco.repo.googledocs=debug
to my alfresco-global.properties in the hope that it would log some relevant debug info, but so far, the log has turned up nothing useful at all. The only entries in the log that appear to pertain to Google Docs at all are entries where the Google Docs subsystem is initialized at startup.

Can anyone suggest a direction to go from here? Thanks for your help.

Outcomes