AnsweredAssumed Answered

Cannot run Alfresco PR 6, tomcat bundle

Question asked by apoorvdurga on Sep 12, 2005
I just downloaded the PR 6, tomcat bundle. However, on starting, i get a lot of exceptions similar to the ones given below. Consequently, the context is not loaded and I cannot access ALfresco.

And i'm using jdk1.5.0_04.

any pointers?

==========================================
Sep 12, 2005 7:10:51 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
Sep 12, 2005 7:11:05 PM net.sf.joott.uno.UnoConnection connect
INFO: connecting using "socket,host=localhost,port=8100,tcpNoDelay=1"…
Sep 12, 2005 7:11:06 PM net.sf.joott.uno.UnoConnection connect
SEVERE: connection failed: com.sun.star.connection.NoConnectException: java.net.
ConnectException: Connection refused: connect
19:02:36,360 ERROR [alfresco.smb.protocol] CIFS server configuration error, Null
value was assigned to a property of primitive type setter of org.alfresco.repo.
domain.hibernate.ChildAssocImpl.index
org.hibernate.PropertyAccessException: Null value was assigned to a property of
primitive type setter of org.alfresco.repo.domain.hibernate.ChildAssocImpl.index

        at org.hibernate.property.BasicPropertyAccessor$BasicSetter.set(BasicPro
pertyAccessor.java:59)
        at org.hibernate.tuple.AbstractTuplizer.setPropertyValues(AbstractTupliz
er.java:207)
        at org.hibernate.tuple.PojoTuplizer.setPropertyValues(PojoTuplizer.java:
176)
        at org.hibernate.persister.entity.BasicEntityPersister.setPropertyValues
(BasicEntityPersister.java:2919)
        at org.hibernate.engine.TwoPhaseLoad.initializeEntity(TwoPhaseLoad.java:
113)
        at org.hibernate.loader.Loader.initializeEntitiesAndCollections(Loader.j
ava:530)
        at org.hibernate.loader.Loader.doQuery(Loader.java:436)
        at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Lo
ader.java:218)

Outcomes