AnsweredAssumed Answered

Problemas com workflow após restauração de backup

Question asked by vitruvio on Jun 5, 2009
Pessoal,

Estou realizando alguns testes relacionados a backup e restauração do Alfresco. Estou até conseguindo restaurar a partir de cópia do root.dir + dump mysql, no entanto, quanto tento iniciar um workflow relacionado a um determinado arquivo, após a restauração, a mensagem ou exceção abaixo é exibida. Alguém poderia ajudar?

Mensagem: "There are no workflows currently deployed in the repository, press Cancel to exit the wizard."

Exceção:

javax.faces.FacesException: javax.faces.el.EvaluationException: Cannot get value for expression '#{WizardManager.bean.hasStartableWorkflows == false}'
caused by:
org.apache.jasper.JasperException: javax.faces.el.EvaluationException: Cannot get value for expression '#{WizardManager.bean.hasStartableWorkflows == false}'
caused by:
javax.faces.el.EvaluationException: Cannot get value for expression '#{WizardManager.bean.hasStartableWorkflows == false}'
caused by:
javax.faces.el.EvaluationException: Exception getting value of property hasStartableWorkflows of base of type : org.alfresco.web.bean.workflow.StartWorkflowWizard
caused by:
javax.faces.el.EvaluationException: Bean: org.alfresco.web.bean.workflow.StartWorkflowWizard, property: hasStartableWorkflows
caused by:
java.lang.reflect.InvocationTargetException
caused by:
org.alfresco.service.namespace.NamespaceException: Namespace prefix imwf is not mapped to a namespace URI

Outcomes