AnsweredAssumed Answered

smbclient to CIFS gives 'BAD_NETWORK_NAME'

Question asked by scottcarson on Jul 13, 2011
Latest reply on Nov 23, 2013 by scottcarson
Hi everyone,

This just came out of nowhere. I've spent days on it and am drawing blanks so I humbly request your assistance.

Alfresco Community 3.4d
Kubuntu Linux

IP Tables are like so:

echo 1 > /proc/sys/net/ipv4/ip_forward
modprobe iptable_nat
iptables -F
iptables -t nat -F
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

iptables -t nat -A PREROUTING -p tcp -d 192.168.3.8 –dport 445 -j REDIRECT –to-ports 1445
iptables -t nat -A PREROUTING -p tcp -d 192.168.3.8 –dport 139 -j REDIRECT –to-ports 1139
iptables -t nat -A PREROUTING -p udp -d 192.168.3.8 –dport 137 -j REDIRECT –to-ports 1137
iptables -t nat -A PREROUTING -p udp -d 192.168.3.8 –dport 138 -j REDIRECT –to-ports 1138

iptables -t nat -A OUTPUT -p tcp -d 192.168.3.8 –dport 445 -j REDIRECT –to-ports 1445
iptables -t nat -A OUTPUT -p tcp -d 192.168.3.8 –dport 139 -j REDIRECT –to-ports 1139
iptables -t nat -A OUTPUT -p udp -d 192.168.3.8 –dport 138 -j REDIRECT –to-ports 1138
iptables -t nat -A OUTPUT -p udp -d 192.168.3.8 –dport 137 -j REDIRECT –to-ports 1137


When I run
smbclient \\\\192.168.2.69\\alfresco -U admin -p 1139

… it works! Meaning Linux connects just fine. But when I do a Win test like this:
smbclient \\\\192.168.2.69\\alfresco -U admin
or
smbclient \\\\192.168.2.69\\alfresco -U admin -p 139

I get:
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

So I can connect but then get kicked out.
This happens when Samba is running. I have cleared /tmp. I have tried it with Samba turned off (which results in CONNECTION_REFUSED.

The only blip is that I changed my server's name from 'CYCLONE' to 'cyclone', but I made the necessary changes throughout the system so that every name/hosts reference does return 'cyclone'

It seems like iptables, but I don't know what else I can do!

Please help! Thanks,
-Scott.

Outcomes