AnsweredAssumed Answered

JLAN with PassthruAuthenticator

Question asked by martinzalc on Jul 19, 2011
Hello,

I'm trying to run a JavaFileDiskDriver in JLAN using "passthru" authentication against a Windows AD. JLAN is running in a Linux machine. I can configure jlanConfig.xml and run JLAN, but when I try to browse that samba share from Windows, I get an error saying "The request is not supported". JLAN configuration is the following:


<jlanserver>
   <servers>
      <SMB />
   </servers>

   <SMB>
      <host name="Hostname" domain="DOMAIN">
         <broadcast>192.168.0.255</broadcast>
         <smbdialects>NT</smbdialects>
         <comment>Alfresco JLAN Server</comment>
         <netBIOSSMB platforms="windows,linux,macosx,solaris" />
         <tcpipSMB platforms="windows,linux,macosx,solaris" />

         <hostAnnounce interval="5" />
      </host>
      <sessionDebug flags="Negotiate,Socket,Tree,Streams" />

      <authenticator>
         <class>org.alfresco.jlan.server.auth.passthru.PassthruAuthenticator</class>
         <mode>USER</mode>
         <Domain>DOMAIN</Domain>
         <allowGuests />
         <Server>192.168.0.10</Server>
         <debug />
      </authenticator>

   </SMB>

   <debug>
      <output>
         <class>org.alfresco.jlan.debug.ConsoleDebug</class>
         <logFile>jlansrv.log</logFile>
         <append />
      </output>
   </debug>

   <shares>
      <diskshare name="JLAN" comment="Test share">
         <driver>
            <class>org.alfresco.jlan.smb.server.disk.JavaFileDiskDriver</class>
            <LocalPath>./share/</LocalPath>
         </driver>
      </diskshare>
   </shares>

   <security>
      <JCEProvider>cryptix.jce.provider.CryptixCrypto</JCEProvider>
      <authenticator>
         <class>org.alfresco.jlan.server.auth.passthru.PassthruAuthenticator</class>
         <mode>USER</mode>
         <Domain>DOMAIN</Domain>
         <Server>192.168.0.10</Server>
         <allowGuests />
         <debug />
      </authenticator>
   </security>
</jlanserver>

Do you see any error in the configuration?

Thanks.

Outcomes