AnsweredAssumed Answered

Some issues with Alfresco 3.4.e and Office 2010

Question asked by manuuu on Aug 16, 2011
Latest reply on Aug 16, 2011 by manuuu
Hi all,

I am new to this forum as well as to the Alfresco World. I have succesfully installed and configured Alfresco these last days. I have tested the CIFS, FTP, LDAP, etc … and everything work fine.

I am very interested in the Sharepoint functionnality. I have tried it into a Windows XP + Office 2007 and it worked great. Then I asked myself what would be the compatibility with Office 2010 and I was very surprised to see that Microsoft changed the way it works as well as Alfresco did.

For me, under Windows 7, it is completely not working :
- I can mount the shared network folder in my explorer (http://<mydomain>:7070/alfresco) after installing the patch (Web Folders)
- I can't open a file directly. I double click it, then it opens Word and …. nothing
- I can, sometimes, open a document in word via the "Open" action, browsing the web folder. I have the versions and can work with it.
- I can't open the workspace in Sharepoint Workspace. It does nothing. I think sharepoint protocol is recognized but that's it (because when I put a wrong url it answers that I put a wrong url).

By the way, I have the exact same issue in Mac OS X with Office 2011.

I have changed "log4j.logger.org.alfresco.module.vti" to debug and that's what I get for Office 2010 :
11:50:33,182 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:50:33,238 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:50:33,238 DEBUG [org.alfresco.module.vti.web.VtiFilter] Check authentication

And for Mac OS X :
11:58:48,899 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:59:04,940 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI
11:59:10,644 DEBUG [org.alfresco.module.vti.web.VtiFilter] Checking request for VTI



I have followed the instructions for the following bug : ALF-3707


Thanks !
Emmanuel

Outcomes