AnsweredAssumed Answered

Problème d'envoi d'invitation ...

Question asked by alex75_2591 on Sep 22, 2010
Latest reply on Nov 2, 2010 by vaquero13010
Bonjour a tous,

Je suis entrain de tester Alfresco community 3.3 sur mon ordinateur équipé de Windows Seven 64bit et je n'arrive pas à envoyer des invitations avec le compte admin. J'ai pourtant configuré comme vu sur le wiki et d'autres posts du forum (anglais comme fr) mais l'envoi est toujours impossible …. C'est pour cela que j'ai fini par poster ici.

Voici un bout de mon fichier alfresco-global.properties

###############################
## Common Alfresco Properties #
###############################

#
# Sample custom content and index data location
#————-
dir.root=C:/Alfresco/alf_data

#
# Sample database connection properties
#————-
db.name=alfresco
db.username=alfresco
db.password=alfresco
db.host=localhost
db.port=3306

#
# External locations
#————-
ooo.exe=C:/Alfresco/OpenOffice.org/program/soffice
ooo.user=C:/Alfresco/alf_data/oouser
jodconverter.officeHome=C:/Alfresco/OpenOffice.org
jodconverter.portNumbers=8101
#ooo.enabled=false
#jodconverter.enabled=true
img.root=C:/Alfresco/ImageMagick
swf.exe=C:/Alfresco/bin/pdf2swf

#
# Initial admin password
#————-
alfresco_user_store.adminpassword=0cac985593bf66a9527ae81f3a0db324

#
# MySQL connection
#————-
db.driver=org.gjt.mm.mysql.Driver
db.url=jdbc:mysql://${db.host}:${db.port}/${db.name}

#
# Oracle connection
#
#oracle#db.driver=oracle.jdbc.OracleDriver
#oracle#db.url=jdbc:oracle:thin:@${db.host}:${db.port}:${db.name}

#
# SQLServer connection
# Requires jTDS driver version 1.2.5 and SNAPSHOT isolation mode
# Enable TCP protocol on fixed port db.port
# Prepare the database with:
# ALTER DATABASE db.name SET ALLOW_SNAPSHOT_ISOLATION ON;
#
#mssql#db.driver=net.sourceforge.jtds.jdbc.Driver
#mssql#db.url=jdbc:jtds:sqlserver://${db.host}:${db.port}/${db.name}
#mssql#db.txn.isolation=4096

#
# PostgreSQL connection (requires postgresql-8.2-504.jdbc3.jar or equivalent)
#
#postgres#db.driver=org.postgresql.Driver
#postgres#db.url=jdbc:postgresql://${db.host}:${db.port}/${db.name}

#
# Index Recovery Mode
#————-
#index.recovery.mode=Auto

#
# Outbound Email Configuration
#————-


# Email configuration

mail.host = smtp.gmail.com
mail.port = 25
mail.transport.protocol = smtps
mail.username = user@gmail.com
mail.password= mypassword
mail.encoding=UTF-8
mail.from.default=alfresco@alfresco.com
mail.smtps.starttls.enable = true
mail.smtps.auth = true
mail.smtps.socketFactory.port = 25
mail.smtps.socketFactory.class = javax.net.ssl.SSLSocketFactory
mail.smtps.socketFactory.fallback = false


#
# Alfresco Email Service and Email Server
#————-

# Enable/Disable the inbound email service.  The service could be used by processes other than
# the Email Server (e.g. direct RMI access) so this flag is independent of the Email Service.
#————-
email.inbound.enabled=true

# Email Server properties
#————-
email.server.enabled=true
email.server.port=25
email.server.domain=alfresco.com
email.inbound.unknownUser=anonymous

# A comma separated list of email REGEX patterns of allowed senders.
# If there are any values in the list then all sender email addresses
# must match.  For example:
#   .*\@alfresco\.com, .*\@alfresco\.org
# Allow anyone:
#————-
email.server.allowed.senders=.*\@alfresco\.com, .*\@gmail\.com, .*\@yahoo\.fr

#
# The default authentication chain
# To configure external authentication subsystems see:
# http://wiki.alfresco.com/wiki/Alfresco_Authentication_Subsystems
#————-
#authentication.chain=alfrescoNtlm1:alfrescoNtlm

J'ai également édité le fichier core-services-context.xml
<!–                       –>
    <!– MAIL SERVICE          –>
    <!–                       –>



    <bean id="mailService" class="org.springframework.mail.javamail.JavaMailSenderImpl">

      <property name="host">

        <value>${mail.host}</value>

      </property>

      <property name="port">

        <value>${mail.port}</value>

      </property>                                        

      <property name="protocol">                          

        <value>${mail.transport.protocol}</value>

      </property>

      <property name="username">

        <value>${mail.username}</value>

      </property>

      <property name="password">

        <value>${mail.password}</value>

      </property>

      <property name="defaultEncoding">

        <value>${mail.encoding}</value>

      </property>

      <property name="javaMailProperties">

        <props>

          <prop key="mail.smtp.auth">${mail.smtp.auth}</prop>

          <prop key="mail.smtp.socketFactory.port">${mail.smtp.socketFactory.port}</prop>

          <prop key="mail.smtp.socketFactory.class">${mail.smtp.socketFactory.class}</prop>

          <prop key="mail.smtp.socketFactory.fallback">${mail.smtp.socketFactory.fallback}</prop>

          <prop key="mail.smtp.timeout">${mail.smtp.timeout}</prop>

        </props>

      </property>

    </bean>

Et enfin le fichier custom-email-context.xml je l'ai créé mais quand je le met dans le répertoire indiqué sur le wiki alfresco démarre anormalement et au login il me dit que les identifiants sont mauvais ou que les fichier n'existe plus ( une fois enlevé alfresco redémarre normalement). Pour info le code est le même que celui mis dans core-services-context.xml.

Pour finir lorsque que je tente d'envoyé une invitation la console tomcat affiche cela :
[img]http://img29.imageshack.us/img29/1663/capture1ud.png[/img]

Je ne comprend pas pourquoi cela ne marche pas. Merci pour votre aide.
Bonne journée a tous

Outcomes