AnsweredAssumed Answered

Problem configuring mail in Ubuntu Amazon EC2

Question asked by jlabuelo on Sep 15, 2011
Hi all

We had alfresco 3.0 ECM running on a windows machine and everything worked fine. We are trying to move the configuration we have to Linux Ubuntu now, and also 95% of the functionalities are working fine, however we have a problem with the mails sent by the server.

In some actions of the application it must send a mail to the users, but with Ubuntu 8.0.4 in Amazon EC2 (where the server is located now)  mails are sent with strange characters, the header does not content the subject or mail origin….

This is the header that the code produces but is not appearing when the mail arrives to destination: (works fine with the application running in Windows).

From: soporte@simplysmart.es
To: agey@simplysmart.es
Subject: Factura emitida por Simply Smart
MIME-Version: 1.0
Content-Type: text/html;charset=UTF-8
Content-Transfer-Encoding: quoted-printable


the body of the email appears in "plain text" and I think it is not taking in account the "Content-Transfer-Enconding".
The configuration worked fine in Windows, but do not know what can be the error that is producing this behaviour
now that we try to move the code to Ubuntu.

Any ideas about what to start looking at??? Does anyone got this kind of
erros anytime before??

Regards.

Outcomes